1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

Beta Release 005 beta firmware

Discussion in 'Beta Firmwares' started by MINIX - Ken, Jan 19, 2016.

  1. MINIX - Ken

    MINIX - Ken Former MINIX Team Member Administrator

    Dear all NEO U1 users,

    We are releasing this beta firmware for testing purpose, hoping to make the official Fw005 release even better.

    This beta firmware has fixed the below problems and adding some new features, include:

    1.) Fixed VPN profile can't save problem
    2.) Fixed the problem that some apps can't cache to external storage device
    3.) Fixed apps being killed automatically when pressing home button
    4.) Fixed no video output problem when screen's EDID can't be detected
    5.) Fixed video output resolution being reset problem
    6.) Added Ethernet soft On/Off switch
    7.) Added faked Wi-Fi status with Ethernet connection
    8.) Added audio offset option
    9.) Enabling gyroscope function of MINIX airmouses
    10.) Fixed incorrect root status being detected by some apps

    Download link:
    MD5 checksum: 5BBB630A50A698381A91C1066930EE6D

    Please feel free to test and provide us your valuable feedback.

    NOTE: Beta firmware won't be able to update via OTA when official 005 firmware is released.

    Thanks and regards,
    Team MINIX.
  2. newbie99

    newbie99 Ex Moderator

  3. MINIX - Ken

    MINIX - Ken Former MINIX Team Member Administrator

  4. kondemor

    kondemor Member

    I am not at home but I understand the Kodi issue is solved and without root it is possible to write and create temporary folders depending on the plugin is ruuning in a HDisk.
    Thanks a lot Ken
  5. paul laughlin

    paul laughlin New Member

    I can confirm that these all appear to function:
    1.) Fixed VPN profile can't save problem
    2.) Fixed the problem that some apps can't cache to external storage device
    3.) Fixed apps being killed automatically when pressing home button
    7.) Added faked Wi-Fi status with Ethernet connection

    One odd problem I did have was that on first use of the play store, as soon as I typed characters into the search, it would crash. This happened a couple of time and then the link to the app from the home screen deleted itself. I then re-added it from the 'All Apps' section and it looked slightly different on launch but didn't crash.

    Apart from that, looking good.

    Thank you :)
    premiump likes this.
  6. MINIX - Ken

    MINIX - Ken Former MINIX Team Member Administrator

    The play store problem should be gone in their latest V6.0.5 , please confirm, thanks.
    Preloaded version is V5.4.12 and has to be updated first.
    According to your description I believe it has been updated automatically and therefore the problem is solved.
    It's their bug. :)
    paul laughlin likes this.
  7. chopper

    chopper New Member

    I am getting MD5 checksum 56f8191805848169add7082f13b15e7d does not match 5bbb630a50a698381a91c1066930ee6d what I am doing wrong?

    Still having the same problem inside the rar file u1 beta file size is 898348744

    Ok got it now was unzipping it before checking it check it when it was rar and said it a match sorry this is the first doing this I usually just do 0ta.
    Last edited: Jan 20, 2016
  8. paul laughlin

    paul laughlin New Member

    Check the size of the download, it should be 471MB. On my first attempt to download, it stopped at around 50mb. Second attempt I got a full download, so try re-downloading and then check the rar file.
  9. Villa

    Villa Administrator Administrator

    You should always use a download manager! (y)

  10. natzen

    natzen New Member

    hdmi state patched in this rom for hdmi drm apps ?
  11. arko

    arko Member

    Dear Ken...
    ViperFX still dosnt work.is it possible to fix this problem in the FW05?
    BTW. thank you for your good work...
  12. MoreMaster

    MoreMaster New Member

    I have two questions:

    1) Is it possible now to save torrents to USB HDD?

    2) How about frame packing in Kodi while watching Blu-Ray 3D Iso? People say that Minix Neo X8H can do it but U1 can make stereo pair only.

    Thanks for reply.
    Last edited: Jan 20, 2016
  13. premiump

    premiump Member

    Excellent news. I don't mind waiting a few more days for OTA :cool::cool:
  14. haru harutachu

    haru harutachu New Member

    hello thanks for your work

    I have two doubts
    I understand when you say about cache app external hdd (i guess kodi and torrents app) but can we write and delete? now are there premisions by external usb hdd ? can we delete whit ftb or samba?

    What about joystick and control compatibility whit games android, is it posible?

    i know about that is posible ask beefore sorry and than you.
    Last edited: Jan 20, 2016
  15. Aztek12

    Aztek12 New Member

  16. paul laughlin

    paul laughlin New Member

    One thing I have noticed is that the VPN graphic on the home page is always grey even when connected. I have connected using the IPVanish app and by setting up a VPN through the network config but it still stays grey.

    Any chance this could be fixed for the v5 proper? It would be good to see from the home screen when connected.

    Thanks very much.
    premiump likes this.
  17. mail2rvg

    mail2rvg New Member

    Does the 'Added faked Wi-Fi status with Ethernet connection' feature mean we can use Miracast using Ethernet and Wi-Fi disabled?
  18. losttoapathy

    losttoapathy New Member

    I can confirm writing to external storage and apps not staying open in background seem be fixed now (points 2 and 3).
    Ethernet ON/OFF switch and "Fake Wifi" also work (points 6 and 7). These are great features, thanks!

    A minor thing about Fake Wifi (not sure if bug or by design): once enabled, ethernet will show as "not connected" and the "fake wifi" switch will not be available, so it can't be turned off. The only way to turn fake wifi off is to turn off wifi itself.
    Disabling wifi means it will not automatically connect if ethernet is unplugged/disabled. It seems gimmicky to have to turn wifi off and then right back on again just to turn off the "Fake wifi" switch.
    I think the "fake wifi" switch should always be visible so it can be disabled without having to disable wifi altogether, right?

    Instead, a major problem i got with this beta firmware is with audio passthrough, not only in KODI/XMBC but any video player.
    If I connect the U1 to my A/V receiver hdmi port, audio passthrough works fine for both DD and DTS.
    If I connect the U1 to my TV hdmi port and audio is sent to the A/V receiver via HDMI ARC, passthrough does NOT work.
    I get a message about an "incompatible audio format" on the TV and no sound is played back.
    The receiver doesn't light up any indicator for DD or DTS as it usually does, so I'm guessing sound is not forwarded from the tv to the amp. Why though, I don't know. Maybe something to do with EDID detection?
    TV is fully capable of DD/DTS passthrough via HDMI ARC so that's not it.
    Standard stereo sound is played back no problem, but i get no sound whatsoever for video files with DD or DTS audio.

    This is not a hardware incompatibility, since I do not have this problem with FW004.
    To make 100% sure, i clean-flashed FW004 again and passthrough via U1->TV HDMI ARC->A/V Receiver works fine with both DD and DTS.
    Flashed FW005 beta again and the problem is back. No DD or DTS sound through TV HDMI ARC.
    Tests have been made on clean installs, right after flashing, with the exact same configuration (Digital sounds set to HDMI in settings, passthrough enabled in XBMC).

    My setup:
    Sharp LC-52LE833 TV
    Pioneer HTP-071 home theatre kit (Exact model of the A/V Receiver unit is VSX-321-K-P)
    Last edited: Jan 21, 2016
    pirsquared8 and kondemor like this.
  19. MINIX - Ken

    MINIX - Ken Former MINIX Team Member Administrator

    What is it?
    Please don't just drop us a name and say it doesn't work...
    We need more information...

  20. MINIX - Ken

    MINIX - Ken Former MINIX Team Member Administrator

    Hi, I use ARC everyday, it's working absolutely fine.
    We didn't modify any audio things from 004 to 005 beta,