1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

Android TV based on FW008

Discussion in 'NEO U9-H Custom ROMs, Kernels & Discussion' started by Kondor, Jun 3, 2018.

Tags:
  1. Kondor

    Kondor Member

    Android TV based on Minix Neo U9-H FW008 (version 001).

    It is clean stock Android TV 6 based on Minix Neo U9-H FW008.

    Description (open)

    • All key functions of Minix Neo U9-H FW008 have been saved.
    • Added TWRP.
    • Status bar in Immersive Mode.
    • Fully working Google Assistant / Voice search. To activate Google Assistant hold Home key or press Google Assistant / Voice key on your remote.
    • Double press Home — Recents Apps (it is from Minix firmware, so it is very bad, in Android 7 it is perfect).
    • Fully working Google Android TV Remote Control.
    • Integrated AppDrawer (for apps without Android TV interface).
    • Apps preinstalled in user space: ES File Explorer 3 (last version without ads and spam), Kodi 17.6, YouTube for Android TV 2.02.14.
    • Partial sleep mode like in other Android TV boxes. Only video signal turning off. You may use RF-remote, BT-remote, mouse, keyboard, etc. to wake up box.
    • If you do not have remote with microphone, just connect microphone (USB or analog) or webcam with microphone to use Google Assistant.
    • init.d in the user space. init.d folder is in the root of user folder. You don't need ROOT to add or edit scripts. Also you don't to set permissions, all will be done automatically.
    • Managed ROOT support. ROOT disabled by default (and not visible for any apps). To enable ROOT open "User space"/init.d/02su file in ES File Explorer Editor and change ENABLE_ROOT=0 to ENABLE_ROOT=1, save and reboot. To disable ROOT change ENABLE_ROOT=1 to ENABLE_ROOT=0, save and reboot.
    • Integrated Samba/CIFS and NFS clients with mounting at user space file system. There are working very fast and accessible for any apps (also without network support).
    How to setup Sambe/CIFS or NFS shares? (open)

    To mount NFS share, open "User space"/init.d/03mount_nfs file in ES File Explorer Editor and change ENABLE_NFS to 1, set share IP (NFS_IP), full NFS path at NAS (NFS_FOLDER) and local folder (LOCAL_FOLDER, you do not need to create this folder manually). Save and reboot.

    [​IMG] [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]

    To mount Sambe/CIFS share, open "User space"/init.d/03mount_smb file in ES File Explorer Editor and change ENABLE_SMB to 1, set share IP (CIFS_IP), folder at NAS (CIFS_FOLDER), local folder (LOCAL_FOLDER, you do not need to create this folder manually) and USER, PASSWORD if you need it. Save and reboot.

    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]


    Screenshots (open)

    [​IMG]
    [​IMG] [​IMG] [​IMG] [​IMG] [​IMG] [​IMG] [​IMG]

    Bugs (open)

    • Google Cast doesn't work.
    • Internal TWRP recovery doesn't work (my mistake in 001e version). Just use standart method with recovery.img on USB or SD card.

    Download firmware (open)

    U9H_FW008_ATV_001e. Use USB Burning Tool (PC) to install U9H_FW008_ATV_001e.img. After login leave system for 5 mins to install all apps and updates.
     
    Last edited: Jun 16, 2018
  2. Villa

    Villa Administrator Administrator

  3. Kondor

    Kondor Member

    Sure, it is made from scratch and based on FW008.
     
  4. immi803

    immi803 New Member

    Wow
    Looks another master piece
    I'll test and report soon

    Any chance next update supports 5 ghz also?

    Thank you
     
  5. immi803

    immi803 New Member

    It has full play Store or Tv OS play Store?
     
  6. Kondor

    Kondor Member

    It is Android TV and it have Android TV's Google Play Store. If you need phone/tablet Google Play Store, just use stock Minix Neo U9-H firmware.

    I don't know, why is 5 GHz mode disabled. I did all standart things (enable dual band also) those worked with other firmwares, but couldn't enable 5 GHz mode.
     
  7. skynet

    skynet Moderator Moderator

    Thanks for sharing (y)

    Do you have the source page / dev page ?
     
  8. Kondor

    Kondor Member

    immi803, kingsizept and skynet like this.
  9. skynet

    skynet Moderator Moderator

  10. SaEt9000

    SaEt9000 Member

    Hi, thanks a lot for sharing this.
    Very exiting to test it.
    I am just playing around with my U9 and some different images - so it comes at the perfect moment :sneaky:

    SaEt9000
     
    Kondor likes this.
  11. skynet

    skynet Moderator Moderator

    Please post your feedbacks ;)
     
  12. SaEt9000

    SaEt9000 Member

    of course ;)


    SaEt9000
     
  13. Khyllion

    Khyllion New Member

    Hi, just booting right now, I will test it and report

    Envoyé de mon SM-G965F en utilisant Tapatalk
     
    skynet and immi803 like this.
  14. Khyllion

    Khyllion New Member

    So... Until now, I was able to install and setup all my apps, Zattoo is working well (I had a bug with official FW008), Netflix too! I don't know where I can check if I get full HD but quality is good, at least 720p.

    Installed N64 and SNES emulators, they are working well with a BT controller.

    Installed smart IPTV, works as well

    I'm able to use the ATV official remote from playstore, just tried a few minutes with KODI (audio pass-through working), YouTube for Android TV works well.

    To summarize, this is exactly what I was looking for! This rom is stable, brings the ATV experience (I use a logitech harmony and don't want to use an air mouse), for me even removed some bugs from Minix original firmware!

    I'm very happy with it!

    Envoyé de mon SM-G965F en utilisant Tapatalk
     
    emilsa, Kondor, kingsizept and 2 others like this.
  15. skynet

    skynet Moderator Moderator

    (y)(y)

    And thanks @Kondor for the rom ! :)
     
    Kondor and Khyllion like this.
  16. Khyllion

    Khyllion New Member

    Of course, forgot to say but many thanks to Kondor!

    I use Ethernet connexion and didn't try 5Ghz wifi but it's mentioned as not working, if this point can be solved, I'm sure many people will use it.

    This rom is Great!

    Envoyé de mon SM-G965F en utilisant Tapatalk
     
    Kondor likes this.
  17. immi803

    immi803 New Member

    I'm testing and found this rom so stable and so good
    huge thanks for this rom

    Secondly, i want to report 5ghz wifi is working with me without issues, just one hiccup at first settings and i reconnected it and it's great, i don't find any bug yet

    Great job (y)
     
    Khyllion and Kondor like this.
  18. immi803

    immi803 New Member

    I want to share that in advanced settings, i checked for mcu update and update was available, without thinking much I've updated mcu and now its v2 instead of previous v1, no issues seen

    I want @Kondor to comment on it, have i done right or any risk I've already taken?
     
  19. Kondor

    Kondor Member

    It is Minix Neo U9-H FW008 in fact (just converted to Android TV as much as I could do with stock FW008), so you may update MCU, there are no risks.
     
    immi803 likes this.
  20. Villa

    Villa Administrator Administrator

    Yes the MCU current version is V2 which appeared with FW008...
    http://www.minixforum.com/threads/neo-u9-h-fw008-20180209.18858/page-2#post-151802
    http://www.minixforum.com/threads/neo-u9-h-fw008-20180209.18858/page-2#post-151808
     
    immi803 likes this.