1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

Another stutter with 4K HDR high bitrate

Discussion in 'Kodi/XBMC for MINIX' started by Huit, Jul 11, 2018.

  1. Huit

    Huit New Member

    Got me a U9-H a while ago and it’s working almost flawlessly, apart from an occasional 4K HDR scene with very high bitrate. In Kodi the image freezes, sound continues and after a few secs image pics up again and everything is resumed perfectly. I’ve tried everything I could think of but nothing worked 100%. I made a short clip from a scene on which it chokes for anyone who would like to try it. The clip plays perfectly on my Windows machine. (I can't post the link yet, since this is my 1st post on the forum)

    This is what I tried so far:
    • I must have read every thread on stutter, buffers, cache, etc…
    • In Kodi 17.6 I think I’ve tried every setting
    • Playing either from network or USB drive doesn’t matter
    • Using these settings in Advancedsetting.xml doesn’t change anything:
    • Kodi 18 Leia, the same problem
    • SPMC is an improvement: some scenes are almost OK apart from a small speed decrease but other (probably higher bitrate) scenes still don’t work. Apart from this SPMC is no solution for me since I can’t get the audio passthrough and refreshrate switch correctly working.
    • LibreELEC is also an improvement, comparable to SPMC but still not OK on all scenes.
    • Playing with other players on Minix gives the same partial improvement as SPMC
    I’m out of options. Anyone an idea?
  2. keanustar

    keanustar Active Member

    I have the same issue with Kodi 17.6. I didn't try anything else. This issue was introduced not long after I updated to FW008. I always play the movies from an USB 3 HDD.

    To partially fix the issue, I cleared all the apps with the option from the Metro Launcher and then re-opened Kodi.

    What I did recently and I thought it fixed the issue was to disable the Minix refresh option, which was set to Level 1. It worked fine until last weekend when I tried to watch Ready Player One 4K BluRay. It stuttered from the start. The Clear All Apps didn't work this time, but a Restart of the U9 did.
    What I noticed is that with disabling the Level 1 refresh works ok, but if you put the Box to sleep, you will get stuttering Video after wake up.

    I was keep telling myself to do another re-install of FW008, but I was too lazy.

    Since I am not the only one, it means that the issue does not resides with me, taking in consideration that I bearly installed any apps other than Kodi and in Kodi I almost have no plug-ins, but the defaults.
  3. Huit

    Huit New Member

    Thanks Keanustar, I'll give your suggestions a go when I get home this evening.

    ps: In 2 days I'll be able to post a link on the forum. I'll share the high bitrate clip then.
  4. skynet

    skynet Moderator Moderator


    Here is a list of high bitrate movie clips : http://jell.yfish.us/

    Can you try to download some of them and try again ?
    Try with 180 Mbits and 200, 10 bits, HEVC

    Maybe your movie is encoded badly
  5. Huit

    Huit New Member

    Thank! I'll try this when I get home.
  6. Huit

    Huit New Member

    OK, that made something clear: even 140 Mbit doesn't play smooth from network and I noticed right away that it was a buffering/network speed problem. From USB drive they play fine, even 200Mbit.

    So, that narrows it down to network I guess. Any ideas how I can test the connection? Other devices on the same network (even the exact same UTP cable) have a 1Gbit connection. It appears that the U9 is on 100mbit....
  7. skynet

    skynet Moderator Moderator

  8. Huit

    Huit New Member

    With an internet speedtest I max out my internet connection which is 200 Mbit.
    I'd still like to know what speed I get from my NFS shares though.

    If I test it within Kodi using Indigo network speedtest I only get 100Mbit (a 1Gig file in 78 secs). But I have no idea how this is tested.
  9. skynet

    skynet Moderator Moderator

    Check your active equipments (switch, router, ..) and ethernet cable.
    Are you connected to a Nas ? Check it too ...
    If you can play high bitrate 4K locally without stutters then it's a network issue
  10. Huit

    Huit New Member

    Yes, going to do some more tests.
    It's connected to a Synology NAS. With a Windows PC connected to LAN I can transfer files at 100Mbyte per sec both ways, so 1Gbit is working fine there.
    Could it be the NFS shares? Until now I've only used NFS with my DuneHD that doesn't do more than 100mbit. I'll try if things work better via UPnP or SMB.
  11. Huit

    Huit New Member

    Some more tests done but still no sollution.
    Cables are fine, if I attach my laptop to the same cable the U9 is connected to, I can pull 100Mbyte per sec from my NAS copying a file.
    Using UPnP or SMB doesn't improve things.
    With LibreELEC the 200 mbps Jellyfish plays smooth but LE doesn't switch to HDR somehow with these samples and LE becomes unstable afterwards.

    Gonna see if I can find anything other to test tomorrow. Somehow I need to increase network throughput in Kodi.....
  12. skynet

    skynet Moderator Moderator

    I don't think so. I use myself a Synology with NFS shares without issue.

    I'm sure you have a network issue. I use a stock Kodi without any changes and i'm able to play big 4K HDR movies from my Synology.

    It's ok with your PC but is it ok with your U9 ?
    You told me you can play all files locally, so it's not a Kodi issue.
    Last edited: Jul 13, 2018
  13. Huit

    Huit New Member

    Thanks for all your input Skynet, much appreciated!

    Did some more testing. Regarding your last question: If I copy a file with X-plore File Manager from a SMB share on my NAS to U9 the transfer speed is about 50Mbyte/sec. That should be more than sufficient. Beginning to wonder if it might be some setting on my Synology that has to do with streaming video. It's a DS414.
  14. skynet

    skynet Moderator Moderator

    yes it is !

    A good one (y)

    Can you reset Kodi configuration ? (Clear cache + data in applications settings)
    Just set autoframerate switch to : At start / at stop
  15. Huit

    Huit New Member

    That actually made it worse probably because Advancedsettings.xml is missing now and cache is lowered.

    Are you able to stream the 180/200 mbit Jellyfish files from your Synology without any stutter?
  16. skynet

    skynet Moderator Moderator

    Yes. Using a DS214, NFS, Kodi 17.6 stock, gigabit connection (verified)
    I also use 2 others NAS (Xpenology) with big 4K movies, no stutters (NFS and SMB shares).

    Uninstall Kodi and install it again from Google play.
  17. Huit

    Huit New Member

    Unfortunately that didn't help either.

    I tried streaming from a shared drive on a local windows PC with a 1Gbit connection. The exact same result. So I guess that rules out something being wrong with the Synology.

    Next step I'm going to try is change my router. But that will take a bit more time before I report back ;)
  18. skynet

    skynet Moderator Moderator

    If you copy your own 4K movie to a USB pen drive, is it working too ?
  19. Huit

    Huit New Member

    No, that specific scene from the movie still chokes the U9 even from USB. But the Jellyfish clips all work even 200mbit.
    I can share the clip but still need to wait 2 days to post link.

    Change of router didn't help :(

    Just did a full factory restore of the U9. Letting it update all now. See if that helps.
  20. Huit

    Huit New Member

    OK another update. After the factory reset I decided to first install SPMC. That fixed the stutter, network throughput was excellent and I could even play the 200mbit Jellyfish from NFS. However, SPMC made a mess of resolution/frame rate switching and after a reboot of the U9 I could only select 1080p or lower in de system settings of U9.

    So, back to a factory reset.

    I wonder what setting is different in SPMC compared to plain Kodi that makes the network throughput so much better....