1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

X5 mini Blue MINIX of death? How to recover

Discussion in 'NEO X5 mini' started by tritto, Oct 3, 2016.

  1. tritto

    tritto New Member

    Hey all. I've been running an X5 Mini for six months or so (although it's out of warranty) and for a few days now it's failed to boot. All I get is the green MINIX logo and it goes no further. I've tried pressing a paperclip into the reset hole while reconnecting power, which gets me to a list of options for booting, resetting factory settings etc. I've tried booting from here, as well as resetting all settings (and losing all data), and a couple of the other options. All to no avail.
    Does anyone have any ideas? Can I insert a USB with the latest firmware (which I'm already on) or do I need to hunt out the male-male USB cable and try to reinstall the firmware via my laptop?
    Has anyone had this issue and recovered it, or is it cactus?
    Thanks in anticipation.

    Sent from my iPhone using Tapatalk
  2. tritto

    tritto New Member

    I guess I should have read a few threads further down before posting. It seems I'm not the only one with this problem. I'll hunt out the cable and have a go at reflashing it.

    Sent from my iPhone using Tapatalk
  3. BMFZ

    BMFZ New Member

    minix neo x5 mini not working dead is t possible