1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

Brand New z83-4 Doesn't boot

Discussion in 'NEO Z83-4' started by SDunker, Jun 13, 2018.

  1. SDunker

    SDunker New Member

    Ok, I have a brand new z83 that I unboxed. Hooked it up to a monitor using the cable it came with, pressed power and just got a blank screen. Tried another cable, same problem. Tried another monitor, same problem.

    So I am not able to see the MINIX Boot screen to even start the Windows setup. I need help or I will have to return this and buy something else.
  2. Villa

    Villa Administrator Administrator

    Can you try connecting it to a TV?
  3. SDunker

    SDunker New Member

    Ok plugging it into my TV worked after I had to wiggle the cable right by the MINIX. hope that doesn't mean there is an issue with the connector.
  4. Villa

    Villa Administrator Administrator

    ...and the monitor?

    I just thought it could be a resolution issue. If it's still not working with the monitor change the resolution while the device is connected to your TV.
  5. MINIX - John

    MINIX - John MINIX Team Member Administrator

    Is the NEO Z83-4 working correctly now? Problem been resolved?