1. Welcome to the official forum for MINIX devices!

Help! Minix neo X-8 plus not working

Discussion in 'General - Guides and FAQ' started by heatherhh2016, Dec 12, 2016.

  1. heatherhh2016

    heatherhh2016 New Member

    My box just stopped working ... I can turn it on and off using the button on the actual box, but the remote is not working. It seems like it's not synced, when the menu is on the homepage there is no indication that the remote is hooked up. I've tried replacing the battery and using the smaller remote as well. Can someone help? Pictures of the remote, box and menu screen are attached

    Attached Files:

  2. mark2

    mark2 Active Member

    try the usb dongle in different usb port press the mouse icon on the remote what happens
  3. heatherhh2016

    heatherhh2016 New Member

    Thanks, I'm new with all of this, which one is the mouse icon?
  4. mark2

    mark2 Active Member

    The one with the circle and arrow inside
  5. heatherhh2016

    heatherhh2016 New Member

    Okay, I have tried all three of the USB ports and pressed mouse button and still no luck!
  6. Higgs

    Higgs Yellow Dude Super Moderator

    Some thoughts;

    Have you replaced both batteries with new ones? Do you see any lights on the remote when you press buttons (Try pressing the Fn button on the keyboard side and see if any of the leds are on, on the other side)
    Try recalibrating the remote - http://www.minixforum.com/threads/instruction-leaflet-neo-a2-lite.6770/
    Try the remote in a pc/laptop or another device.
    Rui Oliveira likes this.