1. Welcome to the official forum for MINIX devices!

How to flash firmware image (X6, X8 series)

Discussion in 'General - Guides and FAQ' started by HardwareGuru, Aug 10, 2014.

  1. toffee970

    toffee970 New Member

    I have BURNING SUCCESSFUL but when I attach bach to the tv and power on it remain on the minix logo also for 5 hours....
    What have I to do?
  2. Magic-Goat

    Magic-Goat New Member

    Are you definitely using the correct version of the firmware for your Minix? That problem can happen if you try and flash an x8 with x8-H Plus firmware
  3. kostas papadopoulos

    kostas papadopoulos New Member

  4. toffee970

    toffee970 New Member

    You are right ... I do not have the plus but the x8-h!
    So now what can I do? Is not there a Lollipop beta firmware for my? And can I recover my uploading the original firmware or do I have to throw it away now?
  5. Magic-Goat

    Magic-Goat New Member

    Lollipop is only ever coming to the X8-H Plus I'm afraid: http://www.minixforum.com/threads/will-the-x8-x8-plus-or-x8-h-get-lollipop.15869/

    You should still be able to just re-flash with the correct version of the firmware and it'll work fine, same update method as before: http://www.minixforum.com/threads/x8-x8-plus-x8-h-official-firmware-009-20160324.11938/

    Good luck!
  6. bvpham88

    bvpham88 New Member

    Hello! I just flashed my minix x8-h plus and i am now stuck at the minix screen with the android waving his arms up. Its been about half an hour and nothing has changed so i think an issue must have came up somewhere along the way...

    i was reading the previous posts and people have said that this firmware only works for the minix neo x8-h plus, im not sure which one i have but the information tag underneath the minix shows

    JX8HPBOX

    ive searched this up and it says its the minix x8-h plus, can somebody confirm?

    this is where i found that it shows my box being the x8-h plus

    https://us.hardware.info/product/272989/minix-neo-x8-h-plus/specifications

    under products.
  7. david durand

    david durand New Member

    Hi all,

    I was stuck on android logo (suddently, no special operation or app install) and impossible to get the recovery mode.
    I decided to use the burning tools to flash a fresh fw.
    The box is recognize but the sw always fails and crash at 22% with a fatal error.
    I tried different usb cable but same problem.
    Im on win10 with a minix x8-h

    Can you please help! Now i have nothing exept a black screen.....

    Thanks

    Mod edit:
    OP posted issue details here...
    http://www.minixforum.com/threads/0...on-system-download-buffer-data-tranfer.17850/

    Similar issue here...
    http://www.minixforum.com/threads/x...-boot-get-download-status-error-result.17817/
    Last edited by a moderator: Oct 10, 2017
  8. dartmango

    dartmango New Member

    Good day. I got ready and was excited to upgrade to lollipop today !!!!

    To my dismay I could not find my USB cord that came with the X8-H Plus (X6) USB TO USB. Are these available at the local computer shop or bestbuy or can I order one here perhaps?

    Thank you kindly.
  9. Villa

    Villa Well-Known Member Super Moderator

    Do you not have any more lying around? For example one that came with a mobile phone.

    You should be able to buy one locally. Just make sure it is a data type not just for charging. They will look identical!

    USB Type A to Micro B

    12-119-265-04.jpg
  10. dartmango

    dartmango New Member

    Actually yes I do. I think I got confused because I recall the the big USB end was longer than the average USB cable.

    Sent from my Nexus 5 using Tapatalk
  11. Villa

    Villa Well-Known Member Super Moderator

    No the other way round, the Micro B end tends to be longer with the MINIX cables. Personally I have never had any issues using other cables.
  12. alejandro rodriguez

    alejandro rodriguez New Member

    Hello,

    I updated my Minix yesterday and it worked( burned successfully). However, when connected for the first time is taking ages and the MINIX/android image is the only thing I can see. Do you have any advice for this? WhenIi say ages, it means more than 6 hours. Am i doing someting workng?

    thank you for the advice
  13. dartmango

    dartmango New Member

    That's great than I'll be rocking the lollipop this afternoon can't wait.

    It's funny I have the mygica 1900atv in my bedroom and I can't stand it. Very unstable. 64 bit device. My X8-H PLUS 32 bit I would it in for the world. Love it.

    Sent from my Nexus 5 using Tapatalk
  14. dartmango

    dartmango New Member

    I don't have easy access to a Windows based computer or laptop. Is there anyway to upgrade to lollipop via flash drive or a Surface tablet that is running Windows software. Preferably the flash drive method though.

    Thx a million

    Sent from my Nexus 5 using Tapatalk
  15. Villa

    Villa Well-Known Member Super Moderator

    This...
    http://www.minixforum.com/threads/flash-x8-h-plus-firmware-from-sd-card-using-burncardmaker.16646/
    ...but you still need Windows. I'm not familiar with Surface so don't know whether it's possible.
  16. dartmango

    dartmango New Member

    Hey that's great. I'll check this out right now. Thanks so much.

    Sent from my Nexus 5 using Tapatalk
  17. Carlos Santos

    Carlos Santos New Member

    PLEASE HELP. I am not very techy and I have the neo minix x8 plus and wanted to upgrade the firmware to lollipop . There are so many links on here and not sure which one of ones I am suppose to us and I really don't want to screw up my box. First time ever doing this and feel stupid. Is there a YouTube video or clear set of instructions I can follow ? Not sure what the process is and what is needed. Thank you in advance.
  18. Jay-Pee

    Jay-Pee New Member

    Hi, I tried this method and got to burn the img successfully. But when I start my Minix, it only has the MINIX logo displayed. Is there supposed to be a progress bar or something when preloaded apps are being installed?

    MINIX Neo X8-H using X8, X8 Plus, X8-H Official Firmware 009
  19. mikemyday

    mikemyday New Member

    Hello,

    I have tried these step by step and it seems now that my minix neo-x8-h does not start up at all. It is looking like it wiped out the old firmware. When I turn it on it gets to the loading screen which shows the minix with the android robot and it doesn't do anything passed that point. I have tried different methods on getting the old firmware installed back on it. If anyone can help me out it would be great. Thanks
  20. IronMonkeyPimp

    IronMonkeyPimp New Member

    Tried the upgrade using 2.06.2 and 2.0.9, I'm on a W10 64 bit PC, and couldn't detect the Minix in the USB Burning tool. My USB connection to the Minix was definitely long enough. W10 doesn't look like it was recognizing the device. Any ideas pls ?