1. Registration issues have now been resolved. New accounts are able to be created

Kodi 17 MINIX X8-H Plus & U1

Discussion in 'General - Guides and FAQ' started by terrypepa, Jan 11, 2017.

  1. terrypepa

    terrypepa New Member

    Need some help ! I've got a Minix Neo X8-H Plus android box. I'm currently running Kodi 16.1 and have tried to update to Kodi 17 Krypton. I deleted 16.1 first then download 17. When I come to install it is says 'there is a problem parsing the package'. I've tried searching Google for answers, but everything I have tried is for phones or doesn't work ..... can anyone help ?

    Cheers !



    Sent from my iPad using Tapatalk
  2. terrypepa

    terrypepa New Member

    Does the minix u1 allow kodi 17.0 to be installed please help



    Sent from my iPad using Tapatalk
  3. the0bone

    the0bone Member

    Why did you posted that in General? And why is your Topic so misleading?

    Yes, why shouldn't that work?
  4. Villa

    Villa Trusted Helper Super Moderator

    Title edited
    Merged posts
    the0bone likes this.
  5. Villa

    Villa Trusted Helper Super Moderator

    Yes!
    Install it from the Play Store.
    terrypepa likes this.
  6. Villa

    Villa Trusted Helper Super Moderator

    Kodi 17 needs Android 5
  7. frank 566

    frank 566 New Member

    Hi! First post ever! I have two X8-plus...running 16.1, so that mean it will not be possible to update to 17???
  8. the0bone

    the0bone Member

    May Villa's post was not clear enough...

    Android 4.4.2 (and all other below Android 5) = Kodi 17 not possible
    Android 5 (and above) = Kodi 17 possible
    Villa likes this.
  9. Tk71

    Tk71 New Member

    Is there anyway round this or just a case of sticking with 16.1?? Have 3 minix boxes n wondering if I need to get new box in near future
  10. midnight

    midnight Moderator Moderator

    Not sure what three boxes you have but unless you have a U1 , Kodi 17 is not possible as stated several, several times here.;) It has been mentioned that 5.0 MAY come to the X8H-plus at some point :).... You can also upgrade to Minix XBMC latest version which I believe is 16.3 or SPMC latest version
  11. frank 566

    frank 566 New Member

    Really disapointed:(. X8H+ were not cheap! I bought Two of them! And it's still on sale! That does't make sence to me...Why almost all other cheap brand are ok to go to 5,1 lollipop. and cost less than haft the price i paid. So i Wonder why i would buy hi quality boxes to end like this? And staying with Jarvis 16.1 is not an option to me. After new version of Kodi come's out, the're is no improvement of the apps for that version. Coders developpe their apps for lastest kodi, that's undertandable. Ok, anough crying, gonna look for two other boxes, capable handling kodi 17.... And there's alot of choice out there....Would have love to stay with Minix,but ending like this pissing me off! (Excuse me for my bad English, not my first language)
  12. the0bone

    the0bone Member

    I don't know any NoName box, that change the OS. And I know / own around 40 different boxes.

    And how do you thing, should this work?
    The different SoCs are made for specific OS Versions. So they don't run native a different one.
    On the time the development of a new box starts, you don't know, what new developments will come in future and that Kodi 17 need at least Android 5 based on used system resources.

    So what should Minix do? Try to make a OS running on a Hardware that don't support it native? And take care about a lot of complains of users afterwards? Just because Kodi 17 might run?

    Go and buy a 2000$ Mac if you like to have 6 years of compatibility. Because even Windows PCs don't do so.
    kingsizept likes this.
  13. Marty

    Marty Member

    So you are saying that @HardwareGuru is wasting his time developing Lollipop for the X8-H Plus and I'm imagining my X8-H Plus currently running on 5.1.1?


    Sent from my iPhone using Tapatalk
  14. the0bone

    the0bone Member

    Where did I say that?

    Nobody is wasting time if he make something new. There are great examples out there of thing's that should not work (Hackintosh for example)
    And like several times posted here in the forum, it makes no sence to post again and again the upgrade requests.
    Also @frank 566 can go here and see the status http://www.minixforum.com/threads/neo-x8-h-plus-to-5-0-lollipop.4838/page-6#post-108223

    I wrote general about expactations. If I buy a Android Unit below 600 Euro (Smartphone, Tablet or OTT), I can't expact to get any upgrade! That is the reason why still around 70% of Android devices on the field have not even Marshmallow installed.
    Source: https://developer.android.com/about/dashboards/index.html

    And I don't understand why people complain for that.
    Last edited: Jan 20, 2017
  15. mark2

    mark2 Active Member

    [QUOTE and I'm imagining my X8-H Plus currently running on 5.1.1?



    If that is so why don't you share with the members how you did this with 5.1.1
    Perhaps they could try it at there own risks
    the0bone likes this.
  16. Marty

    Marty Member

  17. mark2

    mark2 Active Member