1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

Custom ROM LibreElec 9 Kodi 18 "Leia"

Discussion in 'NEO X8-H Plus Custom ROMs, Kernels & Discussion' started by datrh, Sep 3, 2017.

  1. datrh

    datrh Active Member

    -------------------------------------------Kodi 18---------------------------------------------------------
    release info :
    rem : use tar only if you're already running a LE 9 kodi 18 image

    X8/X8H =>

    GZ : http://www.mediafire.com/file/eagtu...H.arm-9.0-devel-20180518203917-b2dc839.img.gz

    tar : http://www.mediafire.com/file/32osa...-X8H.arm-9.0-devel-20180518203917-b2dc839.tar

    X8H-Plus =>

    GZ : http://www.mediafire.com/file/60v84...s.arm-9.0-devel-20180519111357-b2dc839.img.gz

    tar : http://www.mediafire.com/file/twuk5...Plus.arm-9.0-devel-20180519111357-b2dc839.tar

    To boot from SD, you may need to use a build V1.6 to patch your minix bootloader.

    Bugs/non functional/behaviors

    • 3.5mm analog output not working
    • you may have to choose AML-M8audio-spdif in the audio setting
    • you may have to leave "Accelerate Mpeg4" on "HD and up" in the video setting
    • "shutdown" => it send a "shutdown" signal through the hdmi but reboot the minix
    • set "Adjust Display Refresh Rate" to "start/stop" in the video setting
    • instal to internal is broken see workaround
    • all the functionalities coming from the 8.2 v1.6 image (see below) and more...

    kudos to kodi dev team, libreelec dev team and more specifically to surkovalex , Balbes150 , kszaq.
    Without them nothing would have been possible and we wouldn't been able to run LibreElec on our boxes.

    Git stuff

    libreELEC V9 : https://github.com/datrh/LibreELEC.tv
    libreELEC V8 : https://github.com/datrh/LibreElec-8.2

    -------------------------------------------Kodi 17.6-------------------------------------------------------

    Always try the X8H-Series build first and always try to boot it first from usb/sd card, if your X8-HP gives you trouble with wifi or lan, try the X8HP-Gen1 build.

    Use the tar file only if you are certain of the version working on your device.
    Install-to-internal only if you're certain of the version working on your device.

    If you need to activate the "multiboot", make a "boot" folder on the root of the SD card and copy http://www.mediafire.com/file/t1ikkmfk5e05umb/boot.scr in this folder.

    Build V1.6
    changeslog : fix 4K TV compatibility

    X8H-Series :
    tar file : http://www.mediafire.com/file/fey6sh68pknzcln/LibreELEC-X8-H_Series.arm-8.2RC-kodi_17.6-final.tar
    X8HP-Gen1 (to be used is the above didn't give you lan or wifi.) :
    tar file : http://www.mediafire.com/file/bk9ywt5vzq6vegi/LibreELEC-X8-H_PlusGen1.arm-8.2RC-kodi_17.6-final.tar

    With the latest build you get :
    • LibreElec 8.2 RC
    • Kodi 17.6 final
    • Wifi
    • Lan
    • Bluetooth
    • multi-boot (SD,USB)
    • 4k TV compatible
    • 24p support
    • ac3-dts-.. passthrough
    • a lot of dvb-.. drivers
    • XBOX one bluetooth controller support
    • minix ir remote support
    • shutdown workaround
    • smb patch (windows 10 smb v2+)
    feedback are welcome

    Sources : surkovalex , Balbes150 , kszaq

    To update
    • to update you may need to use a " .nocompat"
    • copy tar file to /storage/.update and reboot

    Backup and restore your Kodi sources
    bored to setup again your sources in kodi after having try a new build?

    inbuilt backup
    the manual way
    to backup :
    "ssh" your minix and save at least on your pc :
    /storage/.kodi/userdata/advancedsettings.xml =>mysql cfg, etc
    /storage/.kodi/userdata/sources.xml => smb shares,..
    /storage/.kodi/userdata/passwords.xml => password to access the smb shares

    to restore :
    copy the xml files back to the /storage/.kodi/userdata/
    reboot the box

    Toothpick or not
    if you've already try an image with the "universal" Balbes150 bootloader script (Balbes150 build's, mine,..), you don't need to use the toothpick method.
    Just burn the img.gz on a SD card, put the SD card in your Minix and reboot.

    The toothpick method is needed if the bootloader isn't patched by Balbes150 script.

    SMB and windows 10(must be fixed in the latest build)
    check https://forum.libreelec.tv/thread/9...ndows-10-creators-update-machine-walkthrough/

    or https://forum.libreelec.tv/thread/12310-smb-questions/?postID=90146#post90146

    ps : i don't pretend to be a DEV, i'm more a tweaker than something else.
    Last edited: May 19, 2018
    sangaz, giverxxx, yonatandror and 3 others like this.
  2. windex961

    windex961 Member

    I copied the update tar to the "update" folder on the X8hp and rebooted.. system found the updated, extracted, check sum pass, but the aborts the install stating that it is not compatible with 812 arm... Any ideas?
  3. AxesOfEvil

    AxesOfEvil Member

    After using my image for the past year or so, I decided I wanted to update to 8.2. Before rolling my own, I thought I'd see what was out there.

    I tried the image over on the libreelec forum, and while it kinda works, there is very high CPU load and 8-bit hevc looks terrible (with hardware decoding), and I couldn't get h264 hw decoding to work at all.

    I then tried this build, and it doesn't properly connect to my internal network (wired or wireless) and I still see the high CPU load (~30% on one CPU at idle). Since I have no network access, I can't test playback.

    Do you have a github repo for your build?
  4. windex961

    windex961 Member

    I'm in the same boat... Update with this image and now I don't have internet access at all... Tried a static IP address and still no luck, and dhcp retrieves a 169.x.x.x IP.....
  5. mark2

    mark2 Active Member

    Im getting wifi ethernet and bluetooth so strange that your not
    have you tried going into Libreelec settings and in network switch active off/on
  6. windex961

    windex961 Member

    Yeah I did.. also tried reflashing it a couple times with no luck..
  7. mark2

    mark2 Active Member

    I have tried 3 builds to compare with the one from datrh all left to idle for ten minutes
    this build idled @38% max down to 0% then the usual up and down across all 4cpu
    this one from balbes150
    LibreELEC-S812.arm-17.4_20170830-X8H_Plus.img.gz idled @69% this went down to 0% the other 3 cpu just froze
    these didnt move up or down
    then i tried LibreELEC-S812.arm-17.4_20170830-MXIII_Plus.tar also from balbes150
    this gave me the same results as his other peaking at 69% other cpus froze again
    as for h264 hw decoding running youtube 720p video
    video decoder am-h264 HW
    Deinterlaced method hardware
    system memory 9% CPU 38% 20% 22% 24%
    maybe this can tell you something
  8. mark2

    mark2 Active Member

    Which Android version are you running is it kitkat
  9. AxesOfEvil

    AxesOfEvil Member

    What does this question mean? There is no Android involved in these images, right?

    I have never seen any kernel newer than the one surkovalex had that doesn't have high idle CPU %. This may be due to using a different governor (it has been more than a year since I looked at it), but my Jarvis build from last July definitely feels more responsive (as I said, without any network connectivity I can't test anything)

    As a reference, my Jarvis build from last year runs (hw decoding) ~7%CPU, all others ~1% for both 1280p hevc and h264. But it isn't fair to compare without knowing what the actual CPU frequency is.

    If datrh can provide a build which lets me use network, I can do a better comparison. I think I saw some comments along the line of there being hardware variations on the X8H-Plus...I dunno why your network would be ok, and mine and windex961 not.
  10. senzalice

    senzalice Member

    It might be a good idea for all to mention their player info...i'm sure it may help to identify some issues people are having. This is mine:

    Model: NEO-X8H-PLUS
    Version: 5.1.1 (Lollipop RC2 http://minixforum.com/threads/x8-h-plus-lollipop-rc2-firmware-july-2017.16633/)
    Build: n200-userdebug 5.1.1 LMY47V 20170703 release-keys

    • boots from SD with wifi & ethernet working, auto frame switch OK, DD 5.1 OK
    • only tested 4K video @ 25fps and OK
    • Power Menu OFF works...but cannot switch on via remote (need to pull power plug out)
    • Suspend mode (and then wake-up via remote) is working
    • Reboot is working
    • Reboot from Internal FREEZES my box
    • Windows Network (SMB) not working ....(but I can add a new network place (SMB) and then access my home network)
  11. AxesOfEvil

    AxesOfEvil Member

    Maybe related. I am not dual-booting/running off sd card/usb. I have reflashed the image. on the internal flash drive. It is weird though, since the image does boot up, I'm not sure why it would care if it were dual-booted or not
  12. datrh

    datrh Active Member

    you mean no network at all or name resolution troubles? i personally have resolution trouble but nothing related to the minix, more something with my router or a windows 10 sec fix.

    yes , i will provide all the infos . Actually, it's not up-to-date. i need to sort the mess in my vm, my pc and to sync the things.
    Also a lot of "cosmetics" changes would be nice.

    to resume ,after a lot of trials and errors, the winning combination :
    • a fork of Balbes150 works (all the LibreElec stuff ...)
    • a fork of Kszaq Linux release (needed to get a working kodi 17.4 : you can't stay with a too old linux release)
    • DTBs and wifi drivers from a Surkovalex Linux release (needed to get a functional wifi and SD boot with X8-HP)


    i will build a dedicated img (it will probably not works for X8H_Plus "rev 2" device)
    Last edited: Sep 4, 2017
  13. AxesOfEvil

    AxesOfEvil Member

    My problem is he same as windex961. I get a 169.xxx.xxx.xxx IP address from dhcp. using a static address doesn't make things better. No wireless adapter seems to be found

    Can you explain this:
    I never had good luck with his kernels when I used them (high CPU usage was the issue I think). Do you know what in Kodi needs this? What were the symptoms if you used an older kernel? I'm thinking of trying using your current build but with surkovalex's kernel and video drivers (once you have a repo available)
  14. datrh

    datrh Active Member

    the video driver. EGL errors
    my main focus was to get a working wifi, so i've chosen to not introduce another error factor.

    about the high cpu usage, the "platform_init" and the "CONFIG_CMDLINE" are dependant on who's made the build.
    i mean : surkovlex platform_init/config_cmdline are not the same as the ones of balbes150 and so on.

    eg : surkovalex (openelec 6.0 erea) fixes limits

    linux.arm.conf : CONFIG_CMDLINE="hdmitx=cecf boot=/dev/system disk=/dev/data BOOT_IMAGE=/dev/boot scaling_governor=ondemand scaling_min_freq=96000 scaling_max_freq=1608000 ssh"

    platform_init :
    # Parse command line arguments
    for arg in $(cat /proc/cmdline); do
    case $arg in

    # Boot with performance governor, then switch to the governor specified in the kernel command line
    for cpufreq in /sys/devices/system/cpu/cpu[0-9]*/cpufreq; do
    if [ -n "$scaling_governor" ]; then
    echo "$scaling_governor" > "$cpufreq/scaling_governor"
    if [ -n "$scaling_min_freq" ]; then
    echo "$scaling_min_freq" > "$cpufreq/scaling_min_freq"
    if [ -n "$scaling_max_freq" ]; then
    echo "$scaling_max_freq" > "$cpufreq/scaling_max_freq"

    if you want to venture in the governor things, check this http://linux-sunxi.org/Cpufreq
  15. datrh

    datrh Active Member

    special build for those with lan trouble.(do not use it if build in #1 is working for you)
    it's a "mono" dtb build so i haven't test it on x8-h.
    i dunno if it's boot from SD.

    svankan likes this.
  16. mark2

    mark2 Active Member

    The reason i asked what Android was being used was when Minix released Lollipop Beta i could get certain Libreelec builds running on Lollipop
    others who were still running Kitkat couldnt but when they put Lollipop on there box they could get the same builds to work
    this was using builds on SD card
    but as you have said above it could be because of different hardware variations not OS
  17. AxesOfEvil

    AxesOfEvil Member

    This does indeed work with my hardware (both wireless and wired). I also verified that by using the same minimum-freq (1608000) that surkovalex used, my cpu load is similar to with his kernel, and the performance feels a bit snappier. I'm not sure if it matters or not.

    Hardware h264 works very well. I still get lots of artifacts in 1080p hevc 8-bit sadly.
  18. AxesOfEvil

    AxesOfEvil Member

    In case anyone wants to independently test, I tried the jellyfish samples here:
    Bitrate doesn't seem to matter. For instance the 5Mbps 8-bit hevc sample shows lots of artifacts:

    This played fine on my Jarvis build using hw-decoder, so it isn't hardware related.
  19. windex961

    windex961 Member

    I tried burning this to a USB drive using the burning tool, then paperclip into recovery, select EXT, then Udisk, and the script .zip file, but it fails to install.. is there another way to install this file?
  20. datrh

    datrh Active Member

    there are certainly a few adjustment that must be done in the dtd/dtb.

    it's supposed to uboot the right way. maybe you need to put a boot.scr