1. Registration issues have now been resolved. New accounts are able to be created

M1 is just crap..

Discussion in 'NEO M1' started by Snusman, Feb 8, 2015.

  1. Snusman

    Snusman New Member

    I'm on my second M1 and it failed again with the same problem. The usb port will noT allow for charging . No matter what mini usb i use, the red charging light will not stay lit. If i push the plug in and apply force, I can get the charge light to glow red but as soon as i stop forcing it, it goes out. I'm not replacing with another M! again. Poor product.
  2. Higgs

    Higgs Yellow Dude Super Moderator

    You're entitled to your opinion of course. My M1 is working fine and gets recharged every night. I noticed that it was working ok for you on Dec 29th, so it is just lately that you are having issues with charging it?

    Sent using Tapatalk
  3. Snusman

    Snusman New Member

    The charging on my first M1 failed at the port, so i replaced the m1 a month or so ago, now this m1 is failing in the same manner. There is something faulty with the charging ports.
  4. Lanzalad

    Lanzalad Member

    The stock remote as a complete waste of money and doesnt work on most of the apps.

    I dont know why minix just dont use a stock mouse and do away with the stock remote as it would make a better package.
  5. Higgs

    Higgs Yellow Dude Super Moderator

    This thread is.not about the stock ir remote.
    But I agree to a certain extent with your comment. Android tv boxes like these, need an airmouse/keyboard , wireless mouse/keyboard or bluetooth mouse/keyboard.
    Personally I'd like an A2 Lite with each box.
    Having tested the a2 lite, mele f10, and rii (all of which I use daily) I'd definitely recommend the a2 lite.
    Sent using Tapatalk
    Last edited: Feb 8, 2015
  6. Deco

    Deco Active Member

    i have the M1, A2 lite, Mele F10 pro, Mele F10 Deluxe and of course the stock IR remote and i like them all for different things, and actually no BS i also like my NES30 game controller as TV remote because it's so fast and easy to get around the android system with! - but basically they all do their job, they remote control!

    what i like each model for:

    M1: because it's tiny and very wife friendly, my wife was used to the apple remote and this is much simmilar.

    A2 Lite: very nice feel and large buttons + it has normal batteries! (free choice to use rechargable) - but imagine your using the minix, and the remote dies.. the other RC remotes you have to charge and wait, but this, throw in a pair of new ones and you're ready to continue ;)

    Mele F10 pro: it does NOT have audio card in it like the deluxe has, which in my book is a plus :) - and it works better with my Ouya, but other than that i would compared it to the A2 Lite, just not even near as nice plastic case, you can almost cut yourself on the Mele's :p

    Mele F10 Deluxe: IR Learning! - totally awesome to be able to put away the TV remote!

    NES30: i know it's a gaming controller, but very useable as tv remote for Minix, and it's bluetooth, battery life is ok as it turns off itself after a while of not being used. it works with many games (has 4 different modes it can immitate) and is totally RETRO :D (no airmouse in this though)

    so ALL remotes are good in some fields, and i had no problem with airmouse on any of them, though the F10 Deluxe should have the most precise one due to it's many sensors.

    result: family boxes use M1 remote, for myself a marrige with A2 lite + Mele F10 Deluxe would be heaven ;)

    -Deco
    WeK05 likes this.
  7. droidseeker

    droidseeker New Member

    Hi iam a total newb and can"t get the air mouse working any help for that anywhere ? TIA
  8. Higgs

    Higgs Yellow Dude Super Moderator

    Check that its switched on at the bottom and charged. Click on the airmouse mode button (top left) to enable/disable airmouse function.
    http://www.minixforum.com/threads/m1-user-guide.1002/
  9. Xtian

    Xtian New Member

    My m1 airmouse is not working anymore I bought it last December. I thought if I update my firmware it will go back to normal but it didn't. It was charging at first but after few minutes red light will goes out.. Any advice what to do with this thing... TA
  10. Deco

    Deco Active Member

    droidseeker: remember the pairing and recalibrating from the manual

    Xtian: sounds like either your battery is already charged or it's dead, try the same, off/on, pair, recalibrate.

    -deco
  11. Xtian

    Xtian New Member

    Hi Deco,

    if it's already charge how come it's not working.. I already tried on/off.. I already updated my firmware to 003.. I will try to read the manual on how to recalibrate the M1.. thanks for the advice :)
  12. Deco

    Deco Active Member

    the manual is 3 posts up, and the firmware should have nothing to do with the remote working or not, does it light when you press a button?

    -Deco
  13. Xtian

    Xtian New Member

    Hi deco, no light at all.. I tried pairing but led light is not working


    btw... I think I found the problem with my M1.. the power switch at the bottom is already damaged, it's not attach to the board anymore and need to be soldered.

    Sadly I open it up so the warranty of the unit is gone.

    Thanks for the help guys.
    Last edited: Feb 12, 2015
  14. athlon

    athlon New Member

    My air mouse is having the same issue, you have to hold the cord with force at a weird angle for it to charge.

    Anyone know how to pull them apart
    ?

    Or suggest an alternative remote with pointer or keyboard setup?

    Thanks
  15. droidseeker

    droidseeker New Member

    I have had this for 6 years no problems, works on Mac also. logitech-mx-air-mouse-
    search for a review.
  16. droidseeker

    droidseeker New Member

    ps.about £100 but tops imho.
  17. sangaz

    sangaz Member

    Has anyone changed battery on those yet? Mines not charging any more