1. Registration issues have now been resolved. New accounts are able to be created

M1 pressing up infinitely

Discussion in 'NEO M1' started by Guido, Sep 5, 2014.

  1. Guido

    Guido New Member

    I have a problem with M1 Fly Air mouse.
    When i turn it on, It always press the directional pad up.
    if I press down, it comes right back up, infinitely.
    And if I try to set the fly mode, it doesn't work.
    I have tried several times to recalibrate it, I turn it off and on again, or I change the USB port, but the problem persists.
    What can I do?
    Thanks
  2. uscool

    uscool New Member

    Hi, i have the exact same problem, so just bought a A2 Remote, but the A2 cant wake up the box :(
  3. Frans

    Frans New Member

    Same problem but left instead of up. Sadly no great workaround to share. =/
  4. Try all these trouble shooting steps found in the user guide: http://www.minix.com.hk//downfile/2014061110551888391.jpg

    Then connect your M1 Dongle to the Computer to see if the M1 is still sending repeated presses.

    If it still does that then, it could be sticky buttons as a result of sitting on it. You can try this at your on risk: To fix sticky buttons, paste sellotape over the buttons and slowly peel off the sellotape with a slight pull upward so as to lift up the contact pads under the button. Do not apply so much force as to rip off the buttons :)

    If there were no repeated presses while connected to the computer, it could be that some other keyboards or mice are connected to the box, if not, try backing up all data and doing a factory reset on the box and see.

    If you have multiple fly/air mice, or your neighbors have a M1, they may have cross paired or interfered. Try pairing again and then calibrating.

    If it would have been me, I would have also tried to fully discharge the M1, fully charge, pair and recalibrate it.
  5. Frans

    Frans New Member

    Thank you for your excellent response!

    Calibration doesn't make a difference for me. Neither does pairing anew with the receiver.

    Don't have a tape that's sticky enough to try , but I doubt that it's a stuck button for me, the button sounds and feels like the rest

    Same problem with a computer.

    I left it on overnight, but as I had disconnected the receiver I don't think it drew much power, so haven't tried discharging.

    I've been emailing with Minix support and now got the recommendation to contact the reseller to get it replaced.
  6. tootomthumb

    tootomthumb New Member

    I searched all over this forum for information on how to improve the use of the Neo M1 Airmouse and recalibrate / calibrate it!

    Really annoying that you guys say you did it but dont say how so here it is!

    To recalibrate the mouse (pointer going crazy) set on a level table and press the left and right arrows at the same time until the blue light starts blinking. Let go and it should be accurate again. If not try again, it sometimes takes me more than once!

    Secondly to make it far easier to use you need to reduce the mouse speed. If you have a bar from 0-100 I set it down to around 20%. This is a fast mouse and really benefits from slowing it down to make it much easier to use.

    Except for the short battery life I love this mouse now!
  7. Higgs

    Higgs Yellow Dude Super Moderator

    How to calibrate is described in the manual and also in the very first thread in this Neo M1 section - http://www.minixforum.com/threads/m1-user-guide.1002/
  8. tootomthumb

    tootomthumb New Member

    I hate to point out the obvious but neither the manual (offline paper which 95% of people lose or throw away) NOR the thread you pointed out (a picture FFS, how useful is that?) are searchable in this forum! So you have to be either a Minix zealot or Minix staff to be able to find that information!

    Now of course, after my posting, it is - so nah nah nah nah nahhh
  9. Higgs

    Higgs Yellow Dude Super Moderator

    Well it is the very first thread in the section for a reason. The first place I go when looking for something is the stickies in the relevant section.
    so nah nah nah your self :p
  10. tootomthumb

    tootomthumb New Member

  11. GaryB

    GaryB New Member

    When I received my Minix 8XH+ a few weeks back, I used the M1 remote for about 5 minutes before it packed up. Could not get it working again, even after a recharge. Reading through the forums I understood it to be a bit of a hit and miss affair, and being a "freebie" included with the box I couldn't send it back. The 8XH+ itself was working fine, so I decided to try the M1 on my pc, as suggested in the forums. As soon as I connected it and switched it on, it would run any program that happened to be under my mouse. Aha, there's a key stuck down. Switched the M1 off again, and I created a quick text document in Notepad and put a block of random text in there. Then I positioned my cursor mid document, and switched on the M1 again. Immediately the text separated, getting further and further apart. It was the Enter key on the remote, i.e. the OK button. So I took the remote apart, heck if I can't send it back its going in the bin anyway. Once apart, I could see the keypad/buttons were held in place with a sheet of sticky back plastic (see attached jpg). I peeled the sheet off taking care to not lose any of the metal studs. The M1 was still on, and in mid paragraph, making my text separate. As soon as I pulled the sheet of buttons away from the OK contact pads, it stopped. Put it back, and the problem resumed. Then I noticed the whole sheet was actually slightly misaligned, in that all the buttons (actually metal disc/poppers) were slightly off centre (too low) with the contact. I removed the whole sheet and realigned it, again being careful not to lose any of the metal studs. Bingo, everything started working as normal... for about an hour anyway. Then the OK button reverted back to staying pressed. Maybe the sheet wasn't misaligned after all, and there's just a problem with the actual button/stud.

    So I took it apart again, and this time decided to swap two of the studs... the OK button, with the power button. Reassembled and tested, and it's still working perfectly some 3 weeks later. If anyone does decide to take their remote apart, be careful not to lose the plastic power switch nubbin which can very easily fall off. I did, and spent half hour on my hands and knees looking for it. Best to do it over a flat clean surface. Anyway, I hope this helps others in a similar situation.

    Attached Files:

    Gaetano Felice likes this.
  12. Gaetano Felice

    Gaetano Felice New Member


    Thank you! I had the same problem here, and I solved replacing the plastic sheet!
  13. Mate this worked for me too! My remote works again now! thanks :D
  14. Grant Wilson

    Grant Wilson New Member

    My Neo M1 only works with the usb cable plugged in. Am wondering if its a faulty battery. Can this be replaced. Am using an app called RemoteIME on my Galaxy tablet to control the Minix x8. Works well but still want the air mouse working again