1. Registration issues have now been resolved. New accounts are able to be created

Minix A3 Not Working at all?

Discussion in 'NEO A3' started by Mondoguitar, Jun 19, 2017.

  1. Mondoguitar

    Mondoguitar New Member

    Ordered two A3's off Amazon. One works great, the other my father just opened today as a gift and it doesn't work at all. I plugged the tiny USB receiver into my box, nothing. Have double checked the batteries, nothing. Red light on remote will flicker occasionally, but the only thing you can do is turn our Minix Neo boxes on/off. I checked this on two Nimix boxes I have. Both the same model.

    As soon as I plug my original A3 remote/USB receiver into the boxes, it works great again. I've been using this one all week and love it.

    I submitted a request for a shipping label which will be going out on Monday morning. Was hoping to maybe get some last minute troubleshooting.

    It sure seems like it's DOA. I was able to briefly get it somewhat working, in that the arrow buttons would function, but it was EXTREMELY laggy. Then I tried using the AirMouse, and that too was so laggy that it wasn't useable. Then after 20-30 seconds it just went off completely.

    The strange thing is, you can turn the Nimix boxes on/off successfully every time, but none of the functions work. Can't figure this out.

    Assuming it's just a lemon, and will be ordering a new one. Any advice before I do that? Thanks!
  2. Villa

    Villa Well-Known Member Super Moderator

    The Power button is IR, this is why it works as it doesn't need the USB RF dongle.

    Have you tried recalibration? Fn+Y
    http://www.minixforum.com/threads/instructions-neo-a3.15991/

    You could try this too...
    http://www.minixforum.com/threads/a2-lite-dongle-purchase.15363/#post-127775

    What's a Nimix box?
  3. Mondoguitar

    Mondoguitar New Member

    Thanks for the info. Sorry typo.
  4. Mondoguitar

    Mondoguitar New Member

    Tried re-pairing several times, tried the recalibration commands. Just doesn't work.

    It had to be paired yesterday, because the air mouse and keypad were working, it was just extremely laggy and slow, then it wouldn't work at all. I can't make sense of it. Just re-ordered a couple more remotes.

    Thanks
  5. Villa

    Villa Well-Known Member Super Moderator

    I guess you checked the batteries were good?
  6. Mondoguitar

    Mondoguitar New Member

    Yes, two sets, I think there was a problem with the USB dongle.