1. Welcome to the official forum for MINIX devices!

Minix Neo X7 Mini - Android 4.2.2 - WiFi issues (no connect) [solved]

Discussion in 'NEO X7 mini Custom ROMs, Kernels & Discussion' started by Le Clark, Jun 20, 2017.

  1. Le Clark

    Le Clark New Member

    (i don't know if this have an official thread)

    Since last week the Minix started to fail, reconice the netwotk but don't connect, seems like but not.

    I connected directly to modem/router (Arris TG862) by ethernet cable and then works.
    I tought it was a software issue so i decided to do factory reset.
    After it reboots, tried to connect using WiFi but it failed again... Yes, i checked the net and password were correct, it passed the login fase but didn't made the connection.
    Again, tried with ethernet and then Internet is back.

    Started to look in forums and found that (maybe) is hardware related.

    What i do?
    I connected a WiFi usb dongle (Tp-link)


    This is the model:

    I think it has a "generic" Atheros chip that works like a charm, just connected and that's it. (btw, i used a little usb extension for the WiFi dongle)

    Now i have a working and strong WiFi connection... The best, my son can watch the same Power Rangers ep. all day =/

    Btw, the dongle cost me like 5.00 dollars.

    Last edited: Jun 20, 2017