1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

Neo U1 not powering On

Discussion in 'NEO U1' started by f1Chandra, Jan 30, 2018.

  1. f1Chandra

    f1Chandra New Member

    Hi

    Bought a Neo U1 in September and was reasonably happy with the device. Yesterday I left the device in sleep mode and went out for a few hours. When I came back the device was Off. no LED lights no response to unplugging and plugging back in.

    • There is no LED lights blinking or turning on.
    • I tried holding the power button for 6 or more seconds after unplugging and waiting.
    • I tried different power outlets with no difference.
    • Waited over night and no difference when I plugin and try to power up.
    It seems the device is not receiving any power as its completely dead. I live in a relatively modern building with no power fluctuations or spikes. Not sure what else to try. Could the power supply be the issue or does this device die without any hope of repair. Help?
     
  2. racko

    racko New Member

    Check the power supply first, it could be faulty.
     
  3. f1Chandra

    f1Chandra New Member

    Thanks.

    I suspect so as well. Not sure how to test it though. Looks like I need to find a voltmeter.
     
  4. racko

    racko New Member

    If you don't have a voltmeter try to improvise something. Two wires and a lightning bulb with matching (or close) voltage or try to find a device with a similar power supply and switch them. I think the supplied AC power adapter is 5V / 3A.
     
    Last edited: Jan 30, 2018
  5. midnight

    midnight Moderator Moderator

    I would also suggest trying to locate another PSU to test with
    Output Voltage should be 5v DC and 3000 mA .
     
  6. marooned

    marooned New Member

  7. f1Chandra

    f1Chandra New Member

    Thanks. I could not find a PSU with correct power rating. I will try to find a voltage meter to verify the original is still supplying power. If not I can buy a new power adapter.
     
  8. f1Chandra

    f1Chandra New Member

    Thanks. I will consider this suggestion if the power supply is nto the culprit and update. Might be a few days. Thanks everyone for the suggestions.
     
  9. f1Chandra

    f1Chandra New Member

    Hi All,

    An update on this issue. It turned out to be the power supply adapter unit, after all. I ordered a new one from Amazon and the device is working as expected thankfully. Thanks for your helpful suggestions.

    For this interested this is the replacement I ordered.

    5v minix neo u1 Android box 240v ac-dc power supply unit adapter
    by CableRite
     
  10. Villa

    Villa Administrator Administrator

    I do hope it is OK for you as it appears to be only a 2 Amp PSU.
     
  11. Jeff1982

    Jeff1982 New Member

  12. marooned

    marooned New Member

    Jeff1982 likes this.