1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

Official Release NEO Z64 Android 20150930 firmware (update.zip)

Discussion in 'NEO Z64A Official Firmware Releases' started by MINIX - Ken, Oct 5, 2015.

  1. Higgs

    Higgs Yellow Dude Super Moderator

    Most likely an issue with a) Internet connection, b)DNS server or c) Your browser.
    If your internet connection is okay and your DNS settings are correct then try with a different browser
    No-one will be able to tell you what happened because they don't know what the problem is. You need to give more detail than "I have no success"
  2. ehlim

    ehlim New Member

    Just to tell you that on trying to update firmware, I keep getting
    error message: "not a valid update package"
    using USB thumb drive and rename it as update.zip file.
    I have tried all methods proposed in the forum but still no success.
    Please advise what's gone wrong??
    roy perez likes this.
  3. Villa

    Villa Administrator Administrator

    You need to say which methods you have tried otherwise how can we suggest what you may have missed!

    Did the MD5 Checksum of the file match?
    Use a different USB pen drive?
    Reformat the pen drive! FAT 32
  4. lastway

    lastway New Member

    @MINIX - Ken
    It is possible to know when a new firmware with support for FULL UNROOT will be released? At the moment, I cannot use an app to watch film because my device Z64A is seen as "rooted", so streaming is not possible due to copyright issue.

    Thank you in advance! :)
    Last edited: Feb 28, 2016
    MarioVerdisi and Villa like this.
  5. Villa

    Villa Administrator Administrator

    Waiting for a fix for this too! ;)(y)

    All 4 app reports the device is rooted. :(
    MarioVerdisi likes this.
  6. MarioVerdisi

    MarioVerdisi New Member

    Mine is rooted too. Even if supersu is not installed, it has been reported as rooted.
    Why can't we choose to be rooted or not? All my preferred streaming apps are not working and I bought a minix just for them!!
  7. Villa

    Villa Administrator Administrator

    I don't believe it is rooted! It probably has something to do with SU, the U1 had this issue which was solved with fw005 release.
  8. RaceJay

    RaceJay New Member

    It's semi-rooted or better yet, rootable. The 'exploit' if you will, isn't patched and so, you can run the script with the normal Superuser app that i've posted some time ago ( but i'm not the author of it, just made the modifications so that it installs the Superuser instead of SuperSU ) and have your device rooted.
  9. KingKong

    KingKong Member

    How do i root this ? Ive tried the adb and old root file but dont work.

    Thanks in advance
  10. Colster5

    Colster5 New Member

    I bought a NEO-Z64 in September off Amazon and its Build Number is: 20150413. The Kernel version is: 3.10.20 root@ubuntu #4. The box has an FOTA System update icon, but it always says I'm up to date even though there is a 20150930 update. Does anyone know why this is? Is it because it is rooted? Sorry noob here.
  11. Villa

    Villa Administrator Administrator

    Follow the instructions in Post #1.
    As far as I know and for reasons unknown, this update has not been released via FOTA.
  12. Colster5

    Colster5 New Member

    Thanks for the reply.

    I have tried this, however, I get a message saying the file is not a valid update file. I've downloaded the zip file to a external storage box and connected it via USB to my box. When I click on Check Local, it finds the file and starts to run it. When it gets to 100%, it fails and gives me the error message.
  13. Villa

    Villa Administrator Administrator

    Does the MD5 Checksum match? If not it means the file is corrupt. Please use a Download Manager.

    It also may be because you are rooted!
    Can you unroot then try?
  14. Colster5

    Colster5 New Member

    I'm sorry, I don't know. The Kernel version is: 3.10.20 and says root@ubuntu #4. Does this mean it is rooted? If yes, how do I unroot?
  15. HardwareGuru

    HardwareGuru Developer Administrator

    No it is not rooted.. it referes to the linux user that build the kernel.. no worries
  16. Villa

    Villa Administrator Administrator

    Oh, I thought you said it was rooted?
    I realise now what you were referring to!
  17. AnouarJ

    AnouarJ New Member

    Relatively new device, forgotten in no time. I am so disappointed in you guys where is the OTA? when was the last update ?
  18. midnight

    midnight Moderator Moderator

    What are u disappointed about ?? if you are having issues, why don't u ask for help ? You say "forgotten".... that's just nonsense, they are still supporting a lot older units. OTA hasn't been available but their are other methods to update your box.:rolleyes:
  19. AnouarJ

    AnouarJ New Member

    And my post got deleted! Really???
    Last edited: Oct 3, 2016
  20. Azalin

    Azalin New Member

    They are still supporting older devices? Well, that does not really matter when for the device "we" bought no new firmware updates have been released at all since september last year. That does not really give me any confidence in their ongoing support of a device that is a barely two years old released device. I haven't owned mine for two years, even worst I have it since december and am currently wondering why on earth did I buy an Intel-based system with several apps having difficulties running on it. But that is besides the point. On-topic is more that there has not been an update since somewhere last year, there hasn't even been an update to the latest Android version let alone any security releases. It does really feel like the Neo Z64 Android has been forgotten in the update cycles. I'd rather be dead wrong but it appears to be different. And as for the last update that has been available, I have not updated to it since it still had a lot of problems for various users but these issues also have not been addressed. The device works currently but there are things that need fixing. I am however not prepared to go backwards in functionality and stability.