1. Welcome to the official forum for MINIX devices!

No signal on HDMI

Discussion in 'NEO C, USB-C Multiport Adapter' started by Chechto, Jul 20, 2016.

  1. shuvro

    shuvro Member

    Hello Ken. I having a issue with my HDMI no signal . Also is there any tools for mac to upgrade firmware ??
  2. Amo27

    Amo27 New Member


    I Know this is very old. But my minix Usb-C Multiport Adapter does not work. It´s very new and the hdmi signal goes not to my display. :-(

    I have a macbook 12". Can anybody help me, please?

    Thank you
  3. VinePT

    VinePT New Member

    When trying to update, the orange icon never appears, any feedback?

    EXTRAHELDT New Member

    Same problem here, the adapter doesn't get picked up by the VIA tool. Any solutions?
  5. MINIX - Ken

    MINIX - Ken Former MINIX Team Member Administrator

    Please make sure nothing is being plugged to the adapter when running this step.
  6. VinePT

    VinePT New Member

    @MINIX - Ken

    I tried everything, nothing plugged, plugged to power, with a USB pen connected, using boot camp, using a virtual machine..

    The icon says device 1 and is always greyed out..
    Last edited: May 19, 2017

    EXTRAHELDT New Member

    Same here I'm afraid
  8. VinePT

    VinePT New Member

    Nothing on this....? : (

    EXTRAHELDT New Member

    I've tried everything. Can I just send it to you to have the firmware updated? Op a replacement maybe? I Will gladly pay for the shipping
  10. andreaccs

    andreaccs New Member

    Can I get the Firmware update as well please?
  11. Urosek

    Urosek New Member

    hi I have a MacBook Pro 15" 2016, 2.7 GHz intel core i7, 16 GB 2133 MHz LPDDR3, running macOS Sierra Version 10.12.5 and the HDMI will not register on my MINIX NEO C multipart adaptor. Please advise
  12. Wzwarthoed

    Wzwarthoed New Member

    Can I also get the latest fix for Mac. Im running a MacBook Pro (13-inch, 2016, Two Thunderbolt 3 ports), MacOS Sierra 10.12.5
  13. Jelle Breuer

    Jelle Breuer New Member

    @MINIX - Ken, can i get the latest HDMI drivers too, signal is fine on Windows bootcamp but doesn't connect on Sierra anymore.
  14. pespinel

    pespinel New Member

    @MINIX - Ken I have the same problem "No signal". Macbook Pro (13-inch, 2017, Two Thunderbolt 3 ports), macOS High Sierra 10.13.2 .
  15. KTF

    KTF New Member

    I have the same issue as well on Sierra.
  16. vegetablelasagne

    vegetablelasagne New Member

    Hi Ken, could you send me a copy of the firmware update? I'm running macOS High Sierra 10.13.4 Beta on an Early 2015 12" MacBook, and I'm unable to use the HDMI adapter on the Neo C hub. I'm trying to get a copy of Windows 10 to update the firmware because I received this item as a gift last year but only recently acquired an HDMI monitor and I'm unable to return the item to the original reseller. I would also consider trading it for a replacement if possible. Thank you!