1. Registration issues have now been resolved. New accounts are able to be created

OPENELEC Minix X8/-H/ Plus

Discussion in 'NEO X8-H Plus Custom ROMs, Kernels & Discussion' started by taki, Jan 5, 2015.

  1. senzalice

    senzalice Member

  2. datrh

    datrh Member

    ok
    tks for the feedback.
    so after the install , on the first boot it hang right?
  3. senzalice

    senzalice Member

    It does not install.
    It hangs as soon as the Minix logo and green robot are seen...that's where it stops.
  4. datrh

    datrh Member

    rebuilding my build environment => will make first a x8h img and test it.
    if all ok will adapt the build (dtb + wifi driver) to be able to run a x8hp.
    strange that with the dtb foreseen for x8hp i doesn't boot.. but it's not the first time it happens if i remember.
    Last edited: Aug 13, 2017 at 5:32 PM
  5. ciwy85

    ciwy85 New Member

    Hi just looking in to trying libreelec on my neo x8-h plus, I can see there are problems with wifi but is everything else working fine with kodi krypto? if so can anyone please point me in to where I can find instructions and files on how to get it on to ether sd card or usb to test as a second system next to beta of Lollipop that I'm currently using.
  6. senzalice

    senzalice Member

    I complied the following guide notes... with thanks to mick56 (and also dali).

    How to DUAL boot Minix X8H-plus (currently installed with KitKat or Lollipop RC2)

    I'm using SD Card as it runs faster...but there are only a few images that can boot from SD card.

    You can also use USB stick with other images...the procedure is the same.

    I'm using balbes150 Minix X8H-Plus image because...
    - it boots from SD card
    - auto frame refresh rate works
    - DD 5.1 passthrough works (PCM)
    - ethernet works
    - Wifi & bluetooth not working

    1. Download LibreELEC image - LibreELEC-S812.Minix.arm-17.3.img.gz
    (https://yadi.sk/d/J9pHkMo0uHcKU/MinixH8XPlus/20170605)

    2. Download LibreELEC USB-SD Creator
    (https://wiki.libreelec.tv/index.php?title=LibreELEC_USB-SD_Creator) I used the win32 version.

    3. Write the image to SD card

    4. Create a "boot" folder in the root directory of the LIBREELEC partition of SD card.

    5. Download boot.scr (https://yadi.sk/d/du9BkKk632MbMp/20161112)
    and copy to the "boot" directory on SD card.

    6. Safely remove SD card from computer.

    7. Unplug the power plug from the Minix and insert SD card.

    8. Reconnect power plug

    9. Put your TV on the AV channel of your Minix

    10. Use a paperclip and press the little reset button on the back of the Minix
    You should feel it click and keep it pressed

    11. Press the Power On button for a couple of seconds.

    12. When you see the Minix Green Robot logo appear, release the paperclip from the reset button

    13. Wait and let it boot... it may boot from internal memory to KitKat or Lollipop (whichever you have)
    (In case you end up with the recovery menu...just select reboot system now.)

    14. After it's finished booting, power off Minix and after pull out power plug.

    15. Re-insert power plug and press the Power On button for a few seconds

    16. If all went well it should now boot into LibreElec from the SD Card (or USB).
    (It takes a few minutes until you see the Krypton 17.3 screen)

    17. The next time you Power On, it will always boot to LibreElec when you have SD or USB inserted.

    18. To boot from interal storage (Minix firmware) remove the USB/SD with the LibreElec on it.

    I hope it works for you.
    Last edited: Aug 14, 2017 at 10:16 PM
  7. ciwy85

    ciwy85 New Member

    thanks for the replay, unfortunately after trying many times with different sd cards and usb's it isn't working for me, is there any way to force it to boot trough recovery? as every time I try it just boots in to android


    EDIT:
    So I didn't give up and I have redownloaded the package again this time it worked. Thank you again
    Last edited: Aug 14, 2017 at 11:52 AM
  8. datrh

    datrh Member

    already 2 days i try to get back a build environment...
    i didn't gave up ...
  9. ciwy85

    ciwy85 New Member

    now that I have tested it and everything I need is working nice and smooth - is there any noticeable speed increase when running libreelec from internal memory?
  10. bubblegun

    bubblegun New Member

    That would depend on whether you are seeing any slowness just now.
    If you use a very fast SD card then there will be no difference.
    If your card is slower then menus and images like fan art will be slower to load and this will be faster on internal but then a faster SD card would also fix this.
  11. ciwy85

    ciwy85 New Member

    thanks I will stick to the sd card then, do you guys keep the box on all the time when using libreelec? power button on the remote isn't working for me and after choosing suspend from the kodi power option it wont wake up.
  12. datrh

    datrh Member

  13. senzalice

    senzalice Member

    Tested and boots ok...and auto connects to ethernet.
    Connected to wifi and it runs for maybe a minute or two...and then stops working.
    After I reboot...both wifi and ethernet are connected...system unstable.

    I started again with a fresh image and booted ok.
    I disconnected "wired" connection in menu....and then logged into wifi
    Because I knew wifi only works for short time, I quickly did pastebin of system logs and it worked.
    Here is link... http://sprunge.us/RSMT

    Tried to continue using wifi but unstable...and later system hangs.
  14. datrh

    datrh Member

    ok tks for the update, i will check it tomorrow.
    first read, we need to retry
    nvram_ap6335.txt in place of nvram_ap6335e.txt

    Edit: Does the Bluetooth work?(it works on the x8h)
    Last edited: Aug 16, 2017 at 12:07 AM
  15. senzalice

    senzalice Member

    Yes it connects.
    But I'm not sure how to use it or what to do?
  16. datrh

    datrh Member

  17. senzalice

    senzalice Member

  18. senzalice

    senzalice Member

  19. datrh

    datrh Member

    so bluetooth ok, wifi not ok, SD not ok

    can you try this one => http://www.mediafire.com/file/c7myx3qoc5yjsj8/LibreELEC-MXIII_Plus.arm-17.3_20170807.img.gz

    again need the sprunge link
  20. senzalice

    senzalice Member