1. Registration issues have now been resolved. New accounts are able to be created

OPENELEC Minix X8/-H/ Plus

Discussion in 'NEO X8-H Plus Custom ROMs, Kernels & Discussion' started by taki, Jan 5, 2015.

  1. senzalice

    senzalice Member

    Thanks for your continued efforts and wish you success !
  2. Bennett83

    Bennett83 Active Member

    much appreciated. The x8h+ is still a very good box if you can get everything working in libreelec
  3. datrh

    datrh Active Member

  4. mark2

    mark2 Active Member

  5. senzalice

    senzalice Member

    @datrh
    I just tried it as well and confirm what mark2 as said.
    It first boots from SD card, does the partition resize, then reboots and hangs on the LIBREELEC logo, which is not far from a complete boot.
    You must be very close to cracking this one, booting from SD is so much quicker!!
  6. datrh

    datrh Active Member

    something with kodi... => not really
    something with the framebuffer.. => trying to figure out what (kodi-mali driver dunno if kodi 17.4 gonna runs with old linux)
    Last edited: Aug 24, 2017
  7. datrh

    datrh Active Member

    have integrated old wifi drivers with latest linux 3.10.xx release.
    will test first on x8h.
    release date i guess this week-end
    mark2 likes this.
  8. datrh

    datrh Active Member

    Last edited: Sep 1, 2017
  9. senzalice

    senzalice Member

    @datrh,

    SUCCESS at LAST !!! :D(y)

    Well done...you're never give up attitude has paid off.

    I have tested both 2.4GHz and 5 GHz wifi with no problems at all....for more than 30 minutes.
    I have streamed from the internet and also from my home network...ALL good !!

    Now if only you can get it to boot from SD card...it will be PERFECT !!!

    Thanks for your hard work.
    datrh likes this.
  10. datrh

    datrh Active Member

  11. senzalice

    senzalice Member

  12. datrh

    datrh Active Member

    try to put the boot.scr on the SD without a folder and also overwrite aml_autoscript and s805_autoscript by those from :
    "1. Download LibreELEC image - LibreELEC-S812.Minix.arm-17.3.img.gz
    (https://yadi.sk/d/J9pHkMo0uHcKU/MinixH8XPlus/20170605) "

    the fact that it boot or not from SD is related to these 2 scripts (boot.scr is the binary version of one of those scripts)
  13. senzalice

    senzalice Member

    Yes, did all the above...but still get "file corruption" message.

    On USB it's working good.... and wifi continues to be stable.
  14. mark2

    mark2 Active Member

    I also tried the same as @senzalice and every other way possible
    but @datrh you have got further with this than any other dev so congrats on your hard work
  15. datrh

    datrh Active Member

    @senzalice and @mark2 :

    without both of you testing all the stuff, we would never have a build with a working wifi driver.

    to resume :
    http://www.mediafire.com/file/tz8wejy3h8mgl01/LibreELEC-X8-H_Plus.arm-8.2-kodi_17.4.img.gz

    libreelec with :
    • kodi 17.4
    • lan
    • wifi
    • bluetooth
    • spdif
    • 24p support
    • CEC
    • multiboot support(*)
    • a lot of extra drivers (dvb,....)
    bugs to solve :
    • boot from SD(*)
    • the "classic" shutdown bug (workaround is to use the "suspend" mode)
    • .....
    to have a chance to figure out what's working wrong with the SD boot, i need a link of a working SD build

    edit : you may try one of those s805_autoscript. just download (not the ".txt" one) and copy on the SD.
    source : https://github.com/150balbes/Amlogic_s905/tree/master/script/S805/LIBREELEC

    worst case : it will not boot.
    i would try in reverse order : from the latest to the oldest.

    i can't really test the boot SD because with a X8-H, i never had a SD boot trouble (only with early demetris builds)
    Last edited: Sep 2, 2017
  16. senzalice

    senzalice Member

    This is the link to an image that boots from SD card. I also used the boot.scr and put it in a "boot" folder on SD card
    LibreELEC-S812.Minix.arm-17.3.img.gz (https://yadi.sk/d/J9pHkMo0uHcKU/MinixH8XPlus/20170605)
    boot.scr (https://yadi.sk/d/du9BkKk632MbMp/20161112)
    Sorry...but i'm a bit lost navigating trying to see what "s805_autoscript" to use....very confusing.

    Some more good news:
    I also have another S812 box, it's an OTT M8S.AP6330.201509251800 (KitKat 4.4.2) 2Gb/8Gb
    I'm happy to say that your current build ( http://www.mediafire.com/file/tz8wejy3h8mgl01/LibreELEC-X8-H_Plus.arm-8.2-kodi_17.4.img.gz ) also works on this box with wifi - USB only (SD does not boot)
  17. datrh

    datrh Active Member

    ok i will try to be understandable. will reply later
  18. datrh

    datrh Active Member

  19. senzalice

    senzalice Member

    I have just tried the first one - it comes up with File Corruption message and stops....it does NOT format SD card.

    However, just a while ago before doing the above, I put this image (from before) on SD which boots (LibreELEC-S812.Minix.arm-17.3.img.gz (https://yadi.sk/d/J9pHkMo0uHcKU/MinixH8XPlus/20170605)

    After booting, I put your current image in the ".update folder) and rebooted
    http://www.mediafire.com/file/tz8wejy3h8mgl01/LibreELEC-X8-H_Plus.arm-8.2-kodi_17.4.img.gz

    On reboot, it decompressed the image and reformatted the SD card...but when it rebooted again, the File Corruption message came up.

    I have some other commitments now and will continue the other s805_autoscript tests tomorrow.

    @datrh, do I need to burn a new image everytime I get File Corruption? Or can I just replace s805_autoscript with the next one I want to try?
  20. Tromatik

    Tromatik New Member

    According to my tests the problem does not comes from s805_autoscript or boot.scr

    The ones included in darth latest image just works fine.

    The kernel.img and SYSTEM image included in this image (https://yadi.sk/d/J9pHkMo0uHcKU/MinixH8XPlus/20170605 / senzalice "one") boots fine from SDCARD but not the one included in darth ones.

    I've tried to copy kernel.img and SYSTEM from darth image to senzalice "one" and it not boot from SDCARD. But kernel.img and SYSTEM from senzalice linked image always boots fine from SDCARD.

    My bet is the problem come from ramdisk kernel image and or boot config included in the kernel ramdisk.

    BTW, great to ear that wifi works fine, for the shutdown issue... the suspend alternative is good to me.

    Keep up the good work darth :)
    Last edited: Sep 2, 2017