1. Registration issues have now been resolved. New accounts are able to be created

OPENELEC Minix X8/-H/ Plus

Discussion in 'NEO X8-H Plus Custom ROMs, Kernels & Discussion' started by taki, Jan 5, 2015.

  1. Tromatik

    Tromatik New Member

    It confirms my test, the newly kernel ramdisk installed (from darth image) is then use to boot and fails.
  2. datrh

    datrh Active Member

    ok i will search in this direction.
    tks for the feedback

    edit : maybe something with dts/dtb also.
    when i've try a old linux release, it booted from SD but we had trouble with the opengl/mali.
    it was the same process to build the u-boot things.
    And also the X8-H boot from SD with this build without any trouble (i've always tested all the builds with the X8-H)

    edit2 : can someone tries my build with the dtb.img from a working SD build?maybe it's the clue..Just replace the existing one on the SD card
    Last edited: Sep 2, 2017
  3. mark2

    mark2 Active Member

    @datrh I just tried with dtb.img from the build 0506 said the same file corruption
  4. Tromatik

    Tromatik New Member

    Did not mention that; but i did test this too...
  5. mark2

    mark2 Active Member

    @datrh I have tried all 7 no1 same as usual no2/3/4 new message at top of screen this time
    error in mount_flash could not label boot starting debugging shell type exit to quit
    sh can't access tty job control turned off
    no 5/6/7 with these i get the Libreelec boot logo then i get a new message
    cp can't stat /flash/SYSTEM no such file or directory then 20 seconds later message continues
    error in prepare_sysroot mount common could not mount / dev/SYSTEM
    i have tried them all with/without aml_autoscript and the zip with/without boot.scr
    even swapped them for the same from working one from 06052017
    over on the libreelec forum a few user can't get balbes150 latest builds to boot from sd only usb
    on the page he said he will look into https://forum.libreelec.tv/thread/1506-s812-miii-plus-2gb-16gb-emmc/?pageNo=36
    thanks again for your efforts never been closer to perfect with wifi (which i don't even use myself)
  6. datrh

    datrh Active Member

    ok i will try to find the solution...
    tks to all for the feedback
  7. svankan

    svankan New Member

    I was happy when I read that @datrh solved the wifi problem.
    Wifi and LAN does not work for me with the latest image.
    Any ideas why?
    My box was on pre-order and I wonder if there are different hardware versions of the X8-H Plus?
    I have installed the image on two different USBs but it does not work.
    LAN gives me 169.x.x.x and no wifi at all.
    On the bottom of the box I can see the text NEO X8-H Plus.
    Everything works when I boot on internal memory with Android.
  8. senzalice

    senzalice Member

    @mark2, thanks for your effort, will be great to boot from SD if @datrh finds a solution.
    BTW, is playback of 4K files meant to be working? I've tried a few and they don't work.

    I'm not sure if you're saying you can't boot into LibreElec.....or.....you can boot into LibreElec and you have no ethernet and no wifi?
  9. datrh

    datrh Active Member

    it's just a matter of patching the device tree blob => need to find a patch or made one

    @ testers : can you give me the "fw_printenv" of a working "SD" build and the one you get with the wifi release? (need to compare the 2)
    how-to : ssh the minix and in the console type "fw_printenv"
    i would like to check the uboot.

    this is the "fw_printenv" of the wifi build running on a X8-H :

    /$ fw_printenv
    Warning: Bad CRC, using default environment
    bootargs=console=ttyAMA0,115200n8 root=/dev/mmcblk0p9 rw
    bootcmd=run distro_bootcmd
    bootdelay=2
    baudrate=115200
    arch=arm
    cpu=armv8
    board=hikey
    board_name=hikey
    vendor=hisilicon
    soc=hi6220
    kernel_name=Image
    kernel_addr_r=0x00080000
    fdt_name=hi6220-hikey.dtb
    fdt_addr_r=0x02000000
    fdt_high=0xffffffffffffffff
    initrd_high=0xffffffffffffffff
    mmc_boot=if mmc dev ${devnum}; then setenv devtype mmc; run scan_dev_for_boot_part; fi
    boot_net_usb_start=usb start
    usb_boot=usb start; if usb dev ${devnum}; then setenv devtype usb; run scan_dev_for_boot_part; fi
    boot_prefixes=/ /boot/
    boot_scripts=boot.scr.uimg boot.scr
    boot_script_dhcp=boot.scr.uimg
    boot_targets=usb0 mmc1 dhcp
    boot_extlinux=sysboot ${devtype} ${devnum}:${distro_bootpart} any ${scriptaddr} ${prefix}extlinux/extlinux.conf
    scan_dev_for_extlinux=if test -e ${devtype} ${devnum}:${distro_bootpart} ${prefix}extlinux/extlinux.conf; then echo Found ${prefix}extlinux/extlinux.conf; run boot_extlinux; echo SCRIPT FAILED: continuing...; fi
    boot_a_script=load ${devtype} ${devnum}:${distro_bootpart} ${scriptaddr} ${prefix}${script}; source ${scriptaddr}
    scan_dev_for_scripts=for script in ${boot_scripts}; do if test -e ${devtype} ${devnum}:${distro_bootpart} ${prefix}${script}; then echo Found U-Boot script ${prefix}${script}; run boot_a_script; echo SCRIPT FAILED: continuing...; fi; done
    scan_dev_for_boot=echo Scanning ${devtype} ${devnum}:${distro_bootpart}...; for prefix in ${boot_prefixes}; do run scan_dev_for_extlinux; run scan_dev_for_scripts; done
    scan_dev_for_boot_part=part list ${devtype} ${devnum} -bootable devplist; env exists devplist || setenv devplist 1; for distro_bootpart in ${devplist}; do if fstype ${devtype} ${devnum}:${distro_bootpart} bootfstype; then run scan_dev_for_boot; fi; done
    bootcmd_usb0=setenv devnum 0; run usb_boot
    bootcmd_mmc1=setenv devnum 1; run mmc_boot
    bootcmd_dhcp=run boot_net_usb_start; if dhcp ${scriptaddr} ${boot_script_dhcp}; then source ${scriptaddr}; fi
    distro_bootcmd=for target in ${boot_targets}; do run bootcmd_${target}; done
  10. senzalice

    senzalice Member

    Here is the file containing both outputs for fw_printenv ....

    SD-no-boot - WIFI WORKING
    and
    SD-boot-ok WIFI NOT WORKING

    Attached Files:

  11. datrh

    datrh Active Member

    ok tks.

    at first sight, i don't see any diff.

    when we have tested :
    • the old linux + kodi17.4 => SD was ok but not kodi => we had a freeze with the mali/egl initialisation.
    • the wifi build (wifi drivers from the old linux) + kodi17.4 => SD not ok but no kodi freeze and wifi ok.
    the only diff is the linux version.
    From version to version, there's always changes at least to DTBs, drivers..

    i'm searching...

    edit: building SD first try with old dtbs..
    Last edited: Sep 3, 2017
  12. svankan

    svankan New Member


    I can boot into LibreElec and I have no ethernet and no wifi.
    Today I tried 3 different images:

    1.
    http://www.mediafire.com/file/tz8wejy3h8mgl01/LibreELEC-X8-H_Plus.arm-8.2-kodi_17.4.img.gz
    LAN not ok
    Wifi not ok

    2.
    https://yadi.sk/d/J9pHkMo0uHcKU/MinixH8XPlus/20170605
    LAN not ok
    Wifi not ok

    3.
    https://yadi.sk/d/J9pHkMo0uHcKU/KRYPTON-17
    LibreELEC-S812.arm-17.4_20170830-X8H_Plus.img.gz

    LAN ok
    Wifi It shows wifi networks after boot but not for a long time and it makes the X8-H Plus unstable.

    Do I have a different hardware revision?
    How do I troubleshoot this?
  13. datrh

    datrh Active Member

    i guess yes

    if LAN ok + wifi initialization => DTB ok but linux wifi drivers doesn't fully support your device
    to solve this, a "reverse engineering" of the dtb.img is needed so i can integrate this in the wifi build
  14. datrh

    datrh Active Member

  15. svankan

    svankan New Member

    It would be nice if you could integrate support in future releases of your image.
    Can you tell me what kind of information you need and how to get it?

    I use an old and slow USB memory. Is it a problem?

    Some dmesg information from image with working LAN.
  16. datrh

    datrh Active Member

    1. already done, it will be integrated in the next release
    2. no

    ps:
    http://www.minixforum.com/threads/openelec-minix-x8-h-plus.3342/page-98#post-141175 => need to know if SD boot is possible with this build
  17. mark2

    mark2 Active Member

  18. datrh

    datrh Active Member

    jesus... was a long journey to get this working (y)

    the clue: the right dtbs and the right driver.
  19. mark2

    mark2 Active Member

    I have now rebooted and im pleased to say all is working fine
    So CONGRATULATIONS to @datrh well done
    thank you for all your hard work
    now crack open a beer and give yourself a high five
  20. Tromatik

    Tromatik New Member

    @datrh congrats, boot from SD and wifi working fine!

    I've only encrontred an error while trying to connect a bluetooth xbox controler. No luck for now... maybe an issue with bluetooth.

    Cheers.