1. MINIX team will be having Chinese Lunar New Year holidays from 23/01 to 05/02, replies will be limited during this period, please kindly note.

Option to “Allow installation of apps from unknown sources” doesn’t stay on (Minix Neo X8H-plus)

Discussion in 'General - Guides and FAQ' started by EveningJazz, Dec 6, 2016.

  1. EveningJazz

    EveningJazz New Member

    Greetings everyone!
    I tried finding a solution to the problem below in existing threads, but couldn’t locate one.
    Here goes…
    1) In the Security settings of my Minix Neo X8H-Plus, I turned ON the option “Allow installation of apps from unknown sources.”
    2) Tried to install an Android APK, but got the message “Install blocked. For security, your phone is set to block installation of apps obtained from unknown sources.”
    3) I then went back to the Security settings and to my surprise, the option “Allow installation of apps from unknown sources” was turned OFF.
    4) Tried again, but same result. The problem exists regardless of whether or not I retry the APK install.
    Any help would be much appreciated.
    Thanks.
  2. EveningJazz

    EveningJazz New Member

    Managed to solve the problem.

    Solution:
    1) Went to Permissions --> Personal --> Settings app.
    2) Changed the “Modify Settings” option (towards the bottom of the list) from "OFF" to "ON".
    3) I went back to Security and set "Allow installation of apps from unknown sources" to ON, and this time the setting stuck. I was able to install that APK after that.

    Quick Note:
    Not sure why the “Modify Settings” option was set to "OFF."
    Looks like this was a default, since I've never changed anything in the Permissions section.