1. Welcome to the official forum for MINIX devices!

X7 mini Restoring Kitkat to Fix "Decrypt Storage" error

Discussion in 'NEO X7 mini' started by Mutt Daeng, Mar 10, 2018.

  1. Mutt Daeng

    Mutt Daeng New Member

    A friend asked me to to look at his X7 Mini which was displaying a message something
    like "Enter password to decrypt storage". I've no idea which firmware was on the box.
    I decided to reflash the box with Kitkat v2.50. I used the RKFlashtool and successfully restored the V2.5 firmware.
    When the box rebooted, the following screen was displayed.
    It then entered a reboot loop, alternatively displaying the screen above and this one.
    After about 15 minutes, I pulled the power plug and restarted the box.
    Same thing happpened.
    Then I reflashed the box with V2.4 firmware and after a restart it went into a reboot loop but did not display the above screens. I then tried V2.3 and had slightly better results.
    The following screen was displayed
    After a while, the screen where you decide whether to use the Metro Launcher or Launcher 3 was displayed.
    After selecting Launcher 3, the box rebooted itself.
    Sometimes I got as far as getting into Settings, but once I selected something the box rebooted.
    Then I tried Kitkat community edition. This froze when displaying the splash screen with the developers names on it at startup. I thought the bootloader may be kaput, so I reflashed the Kitkat bootloader using the RKDevelopTool.
    Then I tried V2.50 again and got the same results as above.
    Then I tried v2.30 again and got the same results as above.
    All of the firmware flashes I did worked 100%. Some on Win 10 Pro 64 bit and some on Win 7 Pro 32 bit
    I'm now thinking it's a hardware malfunction.
    Anyone have any other views or hints?
    Thanks in advance

    Attached Files:

    Last edited: Mar 10, 2018
  2. Mutt Daeng

    Mutt Daeng New Member

    Update: I was just about to give up on this when I thought about going back to Jellybean.
    I used the RKDevelopTool to download the jellybean loader to the X7Mini, then used the RKBatchTool to flash Jellybean 20140211 (version 010a) 4.2.2 firmware.
    All working now.
    Villa likes this.