1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

[SOLVED] - Blank screen after recovery failed

Discussion in 'NEO Z64W Guides & FAQs' started by Simmo, Jan 12, 2016.

  1. Simmo

    Simmo New Member

    Sorry, I've searched recovery and black screen and can't find and answer to this.

    I went to the recovery option in windows 10 and nothing happened when I clicked the button. I then selected the other button on the page below which took me to a screen with a blue background with various options and I selected delete my files and recover or reset (can't exactly remember the options now).

    I clicked okay or continue after the warning and the screen with the black background came up with the % centrally at the bottom.

    I left it to do its thing and when I came back there was a blue screen with a message which said something like 'there has been a problem .......' and a cancel button.

    I clicked the cancel button and it went back to the recovery screen with the blue background and I selected continue to windows 10.

    The it rebooted showed the MINIX splash screen and then just a black screen. If I move the mouse the cursor appears and if I right click the egg timer appears, otherwise nothing happens.

    Does anyone know why the recovery failed and is there a fix.


  2. Villa

    Villa Administrator Administrator

    Is this thread useful in any way?
  3. Simmo

    Simmo New Member

    Thanks for the quick reply.

    I had read that thread which seemed to suggest using firmware for another box (pipo?) rather than a bona fide MINIX version.

    I assumed it was a make do and mend which works rather than an official MINIX repair solution?

    I'm guessing that's the only place the iso is available?
  4. Villa

    Villa Administrator Administrator

    You should be able to do a clean install of Windows 10 using this iso file from Microsoft!
  5. Simmo

    Simmo New Member

    Thanks again for the reply.

    I've downloaded the iso from the link onto a USB drive, plugged it in, f11 and then selected flash drive and then nothing. Tried going into the menu with the blue background and selected all the various options is external device/flash drive and I keep going back to the MINIX splash screen followed by a blank/black screen which shows the cursor if I move the mouse.

    One other question, why didn't the recovery work in the first place?
  6. Villa

    Villa Administrator Administrator

    You have to use the MediaCreationTool ! :)
  7. Simmo

    Simmo New Member

    Thanks again for your help.

    Yes, that's sorted it!

    Do you have any idea why the recovery didn't work in the first place? Just to confirm, when I selected recovery nothing happened, now when I select it I am given the two options to keep my files or delete them, I've not gone any further because I don't need to reset it now.


  8. Villa

    Villa Administrator Administrator

    So you everything is back to normal?
  9. Simmo

    Simmo New Member

    Yes, well I think so anyway!

    I had to download and install the drivers as well but that was straight forward though.

    Typical windows though, I've used reset on android plenty of times on tablets, phones and boxes (including my neo x8-h+) and it has never failed, first time on windows 10 and it took a day to sort it out.
  10. berchuzzi

    berchuzzi New Member

    Hi Simmo,

    I'm having the same problem with Windows 10 on my pipo X9. How did you open the MediaCreationTool executable? I downloaded it onto a flashdrive and plugged the flashdrive into the pipo box but I don't know how to open the executable since my box goes to a black screen whenever I boot it up. I have the flashdrive selected as priority to boot in the BIOS screen but nothing changes.

    Any info you can provide would be a huge help. I'm at a loss here.
  11. Villa

    Villa Administrator Administrator

    You run the Media Creation Tool on a PC. It will create installation media for the USB flashdrive which then in turn you connect to the PC you need to install to!

  12. Simmo

    Simmo New Member

    To be honest I can't remember, but whatever I did must have been fairly intuitive. I see villa has replied as well so hopefully that explains it.
  13. berchuzzi

    berchuzzi New Member

    Ahh too easy. Thanks Villa! I'll give that a try.
  14. asoft

    asoft New Member

    Hello berchuzzi,

    Did you manage to solve the problem?

    I have the same problem, I created an installation media with the Media Creation Tool and plugged the USB on my Minix. When I boot it up, after some time I can see the cursor on the screen if I move the mouse but nothing else happens. How can I force Minix Z64 to boot from USB flash drive?
  15. Villa

    Villa Administrator Administrator

    You need to enter the BIOS and change the Boot order.
  16. asoft

    asoft New Member

    Thanks but how do I do that? The screen does not show anything. Only when I see that the TV has got signal from the device and move mouse I see the cursor. If I press DEL or F11 before it does not go that far as to send signal to TV. It is stacked in someway.
  17. berchuzzi

    berchuzzi New Member

    Hi asoft,

    Sorry for the late reply. It didn't work for me but that's because I can't, for the life of me, remember my admin password. I have no doubt that if I had my admin password I could get it working again.

    As for the boot screen, my mini PC would eventually go to the startup screen if I tried unplugging the device and turning it back on. I don't know what it is that causes the startup screen to appear. All I can say is that after 3+ attempts of unplugging the device and turning it back on the startup screen would appear. From there you should be able to access the boot menu.
  18. Villa

    Villa Administrator Administrator

    It is affected by the Fast Startup feature of Windows 10.
    When Fast Startup is enabled the device does not shutdown properly and the BIOS can not be entered unless you select restart or disable Fast Startup.

  19. asoft

    asoft New Member

    Hello berchuzzi and thanks for replying. I finally connected the Minix to a normal PC monitor and was able to see BIOS, initiate recovery and everything. Now the device is working perfectly. I am not sure what the problem is but it seems that when it is connected on my TV it cannot display certain pre-windows screens or something.
  20. Villa

    Villa Administrator Administrator

    Did you check if Fast Startup is enabled?
    While connected to the TV, did you restart instead of shutdown? And did you try disconnecting the power?
    My guess is that you probably had to disconnect the power when you moved it to the PC monitor, which then allowed you to enter BIOS.