1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

Stuck after restart; driver installation

Discussion in 'NEO C, NEO C Plus USB-C Multiport Adapter' started by Reweeda, Mar 2, 2018.

  1. Reweeda

    Reweeda New Member

    hi!

    I'm experiencing an annoying problem after Ethernet port driver installation.
    Once downloaded the last driver and run the pkg for the installation, I restarted my Mac as requested.

    I waited at least 15 minutes and then I realized that my Mac was stuck on boot.
    I forced the shut down and I tried booting up again ending up with the same results, stuck!

    So, I tried to boot up in safe mode.. Again, stuck.

    I tried last the recovery mode and the disk utility tools but my volume appears to be ok.

    So, have I to reinstall OS Through recovery mode in order to eliminate the installed driver? Other solutions?

    I've got a MacBook Pro 13' 2017 without touch bar, it's two weeks old...
     
  2. Reweeda

    Reweeda New Member

    I solved this problem by myself.
    If someone will ever experience the same problem, that's the solution:
    * some expertise in the usage of the terminal are required.

    Start your Mac in recovery mode (cmd+options+R)
    Open the Terminal (just for knowledge: I realised that the terminal of the recovery mode is a bit different from the normal one)

    Now, you have to look at the uninstaller executable that come with the installer.pkg of the driver (the uninstaller won't work inside recovery terminal or I wasn't able to make it works). You can download again the driver image file in another computer or, with the terminal, reach your Download folder (or, better saying, the folder in which you put the image file). Then, just use the hdiutil command tools in order to attach the image file.
    In order to visualize the uninstaller, just use the "cat" command.

    Inside the uninstaller you could check the few commands it would normally run and from them it's possible to understand which file have to be removed. (note that pkgutil doesn't work properly in recovery terminal or, again, I wasn't able to make it works)

    Anyway, just use the "find" command over the main volume reachable from the recovery terminal and "grep" those patterns that match with the file that have to be removed piping the find output. As output you will obtain paths to files, from here it's sufficient to remove (rm) them. (fortunately, pkgutil forget operation is not necessary to solve the problem).

    At the end, exit the terminal, restart your machine and then everything would be back to normal.

    (sorry for my english, it's not my mother language and I don't have the time to check and correct right now)
     
    skynet likes this.
  3. Reweeda

    Reweeda New Member

    Just for knowledge:
    I reinstalled the driver after activating in System Preferences > Security & Privacy the option "Anywhere" for the opening app option. (to do so just type in the Terminal: sudo spctl --master-disable). Everything works fine now.
    Maybe the request of permission during the installation process caused some problems.
     
  4. Vincent01

    Vincent01 New Member

    Hi,

    Experienced the very same issue this afternoon! I’m stuck with this (and I really need my computer these days...)

    Is it possible to explain how you figure it out with a step-by-step tutorial ? (I’m a noob when it comes to terminal stuff)

    Thx a lot!
     
  5. Reweeda

    Reweeda New Member

    - Force Shut Down holding down the power button
    - Start up you Mac in Recovery Mode (CMD(⌘)+OPTION(⌥)+R or CMD(⌘)+R)
    Recovery Mode:
    [​IMG]
    - Go to Utilities > Terminal
    (*) Now it's fundamental you've got the driver folder somewhere in your disk (the folder in which the *.dmg file is). If you deleted it, you have to download it again with another pc.
    (**) "$" stays for: "Type and ENTER in the terminal:"
    (***) "stuff after "#" is comment, it mustn't be typed in the terminal"

    - $ cd ../../../../ #(with this command you reach the main accessible folder of the disk)
    -
    $ find . -name AX88179_178A.dmg #(check for the correct path to the .dmg file)
    (*)you will obtain something like: ./path/to/the/file/we/need/AX88179_178A.dmg

    - $ cd ./path/to/the/file/we/need/
    - $ hdiutil attach AX88179_178A.dmg
    -
    $ hdiutil info
    (*) just copy the last path in the last line displayed by the command, it should be the path of the mounted disk image.
    -
    $ cd /path/to/the/mounted/image/
    (*) if you type and enter ls in the terminal, you should see two files:
    -:AX88179_178A_Uninstall_v150.command
    -:AX88179_178A_v2.9.0.pkg

    - $ cat AX88179_178A_Uninstall_v150.command #(on the screen will be displayed the content of the file)

    Press CMD(⌘)+N in order to open a new TERMINAL window (work here from now on).
    (*) Now consider only lines that starts with "sudo rm -rf" from the other window. Just take care of the file_name after the last "/" in that line (i.e. AX88179.kext, AX88179_178A.kext, etc.). For every file_name do:
    - $ cd ../../../../
    - $ find . -name file_name #(you will obtain a path as above)
    - $ rm /path/to/file_name #(in this way you will remove that file)
    (*) Now consider only lines that starts with "sudo pkgutil --forget" from the other window. Just take care of the file_name after "forget" (i.e. AX88179_178A.pkg, com.asix.pkg.ax88179-178a-10.8, etc.). For every file_name do:
    - $ cd ../../../../
    - $ find . -name file_name #(you will obtain a path as above)
    - $ rm /path/to/file_name #(in this way you will remove that file)

    Now quit the terminal and restart your machine. This procedure fixed the problem for me!