1. Registration issues have now been resolved. New accounts are able to be created

Stuck on Boot Logo

Discussion in 'NEO X8-H Plus Custom ROMs, Kernels & Discussion' started by Marty, Apr 16, 2017.

  1. Marty

    Marty Active Member

    Ok, so this one goes out to the serious techies!!

    As you may be aware I run the MXIII-G 108L1 Lollipop ROM on my X8-H Plus. Generally speaking everything runs fine and dandy but....

    On the rare occasion I have the annoyance of getting stuck on the Google TV boot logo (not to be confused with the boot animation which comes afterwards), I thought this was a conflict with the X8-H Plus and the MXIII-G 108L1 Lollipop ROM but today I discovered I was wrong.

    My standard solution was to flash the box so I took the box to my sons room to flash as my Laptop is packed away and I couldn't be arsed to take it out and boot up, I connected the X8-H Plus to my sons cheap Dikom 24" TV (TLED-2490) and powered up the box, it booted all the way through to my home screen. Thinking it was cured I took it back to my bedroom, connected it to my Samsung 46" (UE46C6700) powered up and was stuck on the Google TV boot logo?? Back to my sons room and it booted to my home screen??

    So, for trouble shooting I thought I would take my sons TV to my bedroom, boot up the box and simply swap the HDMI back to my TV while it was running, it worked!!

    So what in the world would prevent the X8-H Plus from booting correctly on the Samsung?

    - Both TV's display 1920x1080p @60Hz.
    - Same HDMI cable used, others tried but to no avail.
    - Different HDMI ports tried on the Samsung but to no avail.
    - When stuck on the Google TV boot logo I cannot access the box via ADB so I cannot check the boot sequence.
    - CEC is off.

    So, any enlightenment from the Guru's would be appreciated......................
  2. Marty

    Marty Active Member

    In the Samsung TV Menu I turned off Anynet+ (HDMI-CEC), rebooted the X8-H Plus and it booted fine, not sure if this had anything to do with it or if it is just a coincidence?
  3. Villa

    Villa Well-Known Member Super Moderator

    Before my question, I have no answers!
    Does the other TV have CEC settings?
  4. Marty

    Marty Active Member

    Pmsl, love it Villa.

    Nope, no CEC on the other TV. If it is the Samsung CEC then I would love to know how it affects the box, so much so that ADB is disabled. Interestingly, when I unplug the USB from the laptop and plug it back in I get the error in windows that the USB device is not recognised, this is only when it is stuck on the boot logo. If I then run USB Burning Tool the device is detected, very odd indeed.

    No stress, I'm just glad to have found a way to boot up instead of flashing really.
  5. Villa

    Villa Well-Known Member Super Moderator

  6. PLAY911

    PLAY911 Member

    I hace the same problem with a monitor xl2410t...i flashed the same ROM bit stuck un the initial boot....weird!!!
  7. PLAY911

    PLAY911 Member

    Marty just a question....if the hdmi is unplugged does it boot?
    Thx
  8. Marty

    Marty Active Member

    I would have to check, I know ADB works when the HDMI is not plugged in so I could run a boot log and see how far it gets, will let you know
  9. mark2

    mark2 Active Member

    @Marty i had exactly the same problem with my Samsung tv (UE32F4510) to the point of the tv freezing
    at this point i could disconnect the power to the tv and the tv power light would stay on for 20 seconds
    also with the Minix X8H-Plus with the same Rom just staying on the google tv logo
    this has happened with a pi 2 and pi 3 so Anynet + as got to be the problem
    Marty likes this.
  10. Marty

    Marty Active Member

    Update: Just in case anyone else encounters the same issue, bootloader was to blame, correct bootloader taken from the Minix Lollipop Beta and flashed via TWRP, issue resolved.