1. Registration issues have now been resolved. New accounts are able to be created

Stuttering on Kodi 17.1

Discussion in 'NEO U9-H' started by hugorilho, Apr 21, 2017.

  1. hugorilho

    hugorilho New Member

    Basically I bought this thing yesterday and everything appears to be ok except for the stuttering playing videos from my WD My Cloud. Not all videos suffer from this but the 480p ones (ex: my old X-Files collection) are clearly affected. A quick search led me to the possibility of this being due to the framerate adjustment. Everything else on this box, playback wise (exodus, phoenix, netflix) works ok. My previous bedroom box was the beelink minimx III and had no such issue with my WD My Cloud files.
  2. skynet

    skynet Well-Known Member Trusted Helper

    Auto framerate switch must be ON in Kodi, have you set it ?
  3. Gentleheart

    Gentleheart New Member

    Had the same problem. Auto framerate fixed it. Thanks!
  4. Nick_D

    Nick_D New Member

    I'm new to Kodi and the Minix U9-H and am seeing videos streamed from an external drive on my computer exhibit freezing video with ongoing audio (every 5-10 minutes). This lasts 4-5 seconds and then the video 'catches' up to the audio and all is well again for the next 5-10 minutes and then repeats. It appears to only be my SD videos that are affected as I've watched entire 1080p stuff without this issue.
    I've searched all the settings in Kodi (17.1) but cannot seem to find the 'Auto framerate' setting. Can you please tell me exactly where that can be found? Thanks.
  5. hugorilho

    hugorilho New Member

    On Kodi 17 you click on the Settings logo and then Player Settings. Then I set the Adjust Display Refresh Rate option to Always. That did it for me. I would like to thank Gentleheart and Skynet for your help.
  6. Nick_D

    Nick_D New Member

    Thank you for the prompt and detailed reply. In my case, I've just tried it and it doesn't seem to make a difference. However, I've disabled the 'Allow hardware acceleration - MediaCodec(Surface) and MediaCodec'. This seems to correct the issue in the SD videos that I was having. The problem then becomes a very noticeable framerate issue when viewing HD content. After re-enabling the MediaCodecs (both), The HD content plays fine but the SD videos stutter and skip.
    When I get a chance, I may try and convert a few SD files into MKV to see if there could be any issue there.
  7. Gentleheart

    Gentleheart New Member

    Tonight I got the FW003 update and after that the video playback in Kodi was jittering. I was just looking into it and then I got the FW004A update which fixed it again!
  8. hugorilho

    hugorilho New Member

    I've recently noticed this exact issue with my old star trek movies, wich are 480p. It surely must be s912's lack of optimization because my previous s905 TV box had none of these issues. Let's hope that next firmware will fix it permanently.