1. Registration issues have now been resolved. New accounts are able to be created

USB cable

Discussion in 'NEO X7 mini' started by vinz3nt, Sep 11, 2015.

  1. vinz3nt

    vinz3nt New Member

    Hi,
    I seem to have misplace my original x7mini USB cable, the male-male one.
    I looked everywhere.
    I found a cable which originally was used for an external harddrive, this is also a male-male one. But when I plug it in the x7mini and my laptop, nothing is found in Windows.

    Is the minix cable different? Maybe I have to cross the data wires? I have tons of USB cables so I can make one myself so if anyone has a pinout scheme of the cable this would be nice.

    I do get into TWRP 2.7 with booting with the paperclip. But also if I attach a mouse and a keyboard I can't do anything at all.

    Or is there another way?
  2. mikaelkj

    mikaelkj New Member

    "Funny" I have the exact same issue and have been searchin the last few days for som specs for the cable... I also have another cable that doesn't work (unless the issue is another)... Anyone have info on the pins ...? (sorry to get your hopes up by replying without an answer (n) )
  3. mikaelkj

    mikaelkj New Member

    I am guessing the process of creating my own would be somewhat similar to making an OTG cable .. and that involves crossing the data connections - but also grounding the sense pin on one end... But since the A-type plug dosn't have a sense pin I'm guessing it doesn't matter in this case... Going to try out crossing the data pins :)
  4. mikaelkj

    mikaelkj New Member

    So... seems to work--- but now have a new issue - the device is just detected as USB\DEVICE_DESCRIPTOR_FAILURE
  5. mikaelkj

    mikaelkj New Member

    Tried another cable to make sure - actually used the other male-male cable - and switched the two data wires since they where straight through... Same issue ... Unrecognized device...
  6. Villa

    Villa Well-Known Member Super Moderator

    I think you will find that a USB Male A to Male A is wired 1 - 1, 2 - 2, 3 - 3, 4 - 4

    upload_2015-9-14_22-49-32.png
  7. mikaelkj

    mikaelkj New Member

    Yes - but that doesn't seem to work... The cable for the X7Mini seems to have pin 2 - 3 crossed... Which would make sense - like an OTG cable...
  8. vinz3nt

    vinz3nt New Member

    It's strange, I can connect a mouse, keyboard and USB drives and they al work fine. I tried different cables, (USB A male-male straight, crossed, OTG), my laptop doesn't even see an unknown device, just nothing.

    I was able to flash a new ROM since I have managed to install a custom recovery (TWRP) in the past. If I power-up with reset pressed I can get into the recovery and flash a ROM from a SD card. I was even able to update TWRP since I had an old version.

    But it's still strange that there is no way to connect the X7mini to my laptop at all.
  9. vinz3nt

    vinz3nt New Member

    But if your computer at least finds an unrecognized device, it probably is a driver issue
  10. Villa

    Villa Well-Known Member Super Moderator

    How do you know if you can't find it?

    I can not check as I do not have an X7 Mini or a lead!
  11. Teodorico Flores

    Teodorico Flores New Member

    Any update please?
  12. Villa

    Villa Well-Known Member Super Moderator

    Any update to what?
  13. Teodorico Flores

    Teodorico Flores New Member

    If the x7 usb cable with pins 2 & 3 crossed does work.