1. Registration issues have now been resolved. New accounts are able to be created

Beta Release X8-H PLUS Lollipop RC2 firmware (July 2017)

Discussion in 'Beta Firmwares' started by MINIX - Ken, May 27, 2017.

  1. sob80sup81

    sob80sup81 New Member

    Yes, after updating i no longer able to write into external HDD either by addons or torrent.

    Appreciate if anyone can share the way to resolve this.
  2. Coen Linskens

    Coen Linskens New Member


    New
    Yes all apps give no sound!
  3. ozbrit

    ozbrit New Member

    Will this lollipop upgrade graduate to a final release to be pushed out to devices and which can then be installed in the normal fashion, so us un-technical types can enjoy it?
  4. Kellman

    Kellman New Member

    Please refer to Post #1

    "This beta firmware"

    and

    "Please note that beta firmware users will not receive future FOTA updates.
  5. Kellman

    Kellman New Member

    To anyone experiencing sound, read & write or video issues...do what I did to ensure this works 100% . Either factory reset first or restore to previous kitkat firmware before installing RC2.

    This has worked for me and I can report my A2 Air Mouse, Sound, Video (HDMI), read & write access to HDD or USB drives all working 100%.

    So far the only bug I have encountered is, when using the Google Launcher as my home screen, if I click and drag any icon shortcut to the bottom "quick launch bar" the system freezes and must be rebooted in order to get the system up and running.
  6. sob80sup81

    sob80sup81 New Member

    And by previous Kitkat firmware, you're referring to this? http://www.minixforum.com/threads/official-x8-h-plus-011-firmware-20170119.15681/
  7. ozbrit

    ozbrit New Member

    Indeed but do you recognise the ambiguity in the statement? I saw it and guessed that it mean't "NO" x8-plus devices will receive this upgrade as a FOTA upgrade" but when I saw a youtube - how to upgrade to lollipop video and in it the author was confidently 'predicting' that there would be a final (not beta) FOTA and the statement here remarks only about beta firmware users. I needed clarification. After all "beta" means "before/pre-cursor/test stage" to something, in this case it precedes nothing at all.

    You can see how confusion can be caused.

    Thanks for the confirmation, that the upgrade is manual only. If you want it, you have to do it yourself - I'm now assuming that that's what you're advising.
    Last edited: Sep 15, 2017
  8. Kellman

    Kellman New Member

    Yes, for those who already have installed Lollipop Beta RC1 or RC2 it's best to roll back to any official Kitkat firmware and then install the Lollipop RC2.

    For those of you who have not yet attempted the Lollipop Beta and are still on Kitkat, I recommend a factory reset before before installing the Lollipop RC2.

    This has worked for me.
  9. lev2k

    lev2k Member

    Absolutely irrelevant, which firmware (or even none) is installed on the box when flashing LP/KK or anything else like custom roms.
    The "USB flash tool" wipes the former OS completely and formats the internal memory anyway.
    ....
  10. borra

    borra New Member

    Hi guys,
    Long time watcher of this thread. Bite the bullet last week and upgrade my Minix to LP beta. Found out that only Minix XBMC 16.3 works without problems. All the other 17.x versions have sync problems between video and audio.
    Tried the special settings explained a few pages ago (amlogic and sync) but no improvement.
    Because the Minix XBMC 17.4 was not installing, I had to uninstall version 16 to manage the install.
    After all the problems with 17.x players decided to revert back to KK. Found out that the Minix XBMC 16.3 did not come back after the reflash. Upgraded to LP and still no 16.3 player.
    In the end I have downloaded the apk file from the forum and installed it. Can anyone explain this?
    Any other tricks that I can test in LP+17.x players to get the video/audio stay in sync?
    Thank you.
  11. PatB21

    PatB21 New Member

    Hi,
    l'application myCanal ne fonctionne pas avec cette version!
    Quelqu'un a une solution ?
    Merci

    Hello,
    I have just updated my MINIX X8-H Plus to Lollipop RC2 and I find that myCANAL application does not work!
    Has anyone ever noticed this problem?
    Thank yo
    Last edited by a moderator: Sep 15, 2017
  12. midnight

    midnight Moderator Moderator

    English please !
  13. Pamgsk

    Pamgsk New Member

    Hi,
    On the title of the post says "This firmware beta is not for x8 x8h plus users etc"
    So my question is :For what device is the update?
    Can't I use it to update my minix neo x8-h?
  14. Jeffers24

    Jeffers24 Active Member

    I think you misread the message:-

    (This beta firmware is NOT for X8, X8 PLUS or X8-H)
  15. Villa

    Villa Well-Known Member Super Moderator

    The clue is in the title!
    X8-H PLUS Lollipop RC2 firmware (July 2017)

    No
  16. Marty

    Marty Active Member

    Herewith a bit of useless information, there is a post on the forum explaining how to install the Probox Lollipop ROM onto the X8-H, the funny thing is I installed the Probox ROM on my X8-H Plus before Minix released this beta Lollipop ROM for the X8-H Plus. So my thinking is, if the Probox ROM runs on both boxes then why not be a pioneer and try this on the X8-H, you can always flash back if it fails
    Villa likes this.
  17. Villa

    Villa Well-Known Member Super Moderator

    Maybe WiFi breaks like reports in the past when one has flashed the wrong firmware for either device.
  18. lev2k

    lev2k Member

    Probox, Wetek Core and the X8-H Plus have the same SoC (S812)!
    The X8-H has a S802 SoC and also most probably different Network/Sound, etc. Hardware.
    So the "X8-H Plus ROM" will definitely fail to run on the X8-H.
    I think, it won`t even boot, but I see a very good chance, to brick the device (n)
  19. sob80sup81

    sob80sup81 New Member

    Thanks! I did this earlier, flashed to latest official Kitkat and Lollipop RC. Downloading torrent as i typed.

    Cheers.
  20. colonol

    colonol New Member

    I'm still on rc1 and haven't been using the box much. I have the last few days though and noticed my pure vpn only worked via their app for 5mins and then stops working.

    It stays connected to the app but the internet no longer works. When I turn the vpn off the internet works again.