1. Registration issues have now been resolved. New accounts are able to be created

YouTube App on X7: sound, no video

Discussion in 'NEO X7' started by Yujah, Sep 7, 2017.

  1. Yujah

    Yujah New Member

    Good day.

    I'm using an X7 with the official Kitkat 250 firmware and am having problems with the YouTube app; not with all videos, but for a relatively large number of them sound plays, but video is black. As an example, I've not been able to get the following video to play in the YouTube app (newest, currently version 12.32.60) :



    Would anyone be able to confirm or deny the issue and if so, could you be explicit about the firmware version you're on? Note, the above video does play in Firefox running on the X7; it's only the YouTube app that has the problem. Don't know how to provide a "YouTube-App link", if that's even possible.

    I do not myself use YouTube but a visiting child runs into the issue constantly. I recently upgraded my home network to wired from wireless and thought that would be it; i.e., YouTube-app auto-selecting a higher quality that the X7 then trips over, but actually unplugging ethernet and re-connecting via WiFi doesn't help; the video still doesn't play (including after rebooting the X7). I also tried all HLS configuration options in the Android settings and none of them make a difference.

    My connection speed is approximately 70 Mbps over wired; as said though, it doesn't work to switch back to WiFi, nor to set the video to for example 240p. Can anyone help? You'd be doing the mentioned child a big favor. I believe this started only recently, but am not myself sure.

    [EDIT] I see that my youtube-link has auto-turned itself into an embedded video, but please note, I'm only after a report for the YouTube app. I'm sure that the video will play through browsers here. The title of the video is "When costumer refuses to pay"; if someone could search for it in the YouTube app on X7 and try it, that would be great.
    Last edited: Sep 7, 2017
  2. Yujah

    Yujah New Member

    No one using an X7 that could give this a try for me? Sort of need to know how local the issue is before being able to investigate further..
  3. Villa

    Villa Well-Known Member Super Moderator

    I will try a soon as I can.
  4. tincu

    tincu New Member

    I have had the same issue for the last month. Whenever I try to watch a 60fps video on YouTube, I get a black screen but the sound works fine. What I've noticed - even if I force the video quality in YouTube app to 480p, 360p or 240p, the image still doesn't work.
    I tryed all options in HLS configuration with no succes.
    However, if I change the resolution in settings, all the other options work fine - 1920x1080 50hz, 1280x720 and so on. The problem is that the image overall is very bad - over sharpened and over saturated colors .
    I found older versions of YouTube on apk mirror but none of them work in 60fps.
    I know we have quite an old device (NEO X7) but I really don't plan to buy a newer one since this one works well in general.
  5. Yujah

    Yujah New Member

    Thank you for the reply. Didn't get an email notification for it so took me a bit to notice...

    Not sure about the 60 FPS thing; can not even get the YouTube app to display any interesting information (stats for nerds? where?) to be honest but video is generally around 25 or 30 frames per second; 50 or 60 is normally a refresh rate. Unfortunately I also can't verify the second part of your reply: here, the HDMI output mode in the Android settings does not matter for for example the above linked video when played in the YouTube app. My normal mode is 1920x1080@60 (on a 1920x1080 TV) and with neither 1920x1080@50 nor 1280x720 at any refresh rate do I get anything other than the black screen. Or did you mean something else with "change the resolution in settings"?

    As such, reports still very welcome...
  6. charlesp

    charlesp New Member

    Same here, about 2 weeks ago a Youtube upgrade broke the videos.

    A video can be black or work. Sometimes the same video a few hours later will work, sometimes not. It`s very frustrating (I use my phone to cast the video when that happens)

    I tried the HLS settings in the display menu but I don`t see any improvement.
  7. Yujah

    Yujah New Member

    Thanks a bundle. Was due to own non-use of YouTube specifically not (fully) sure if this was indeed a recent thing. Let's hope Villa has an idea for fix/workaround then. Or an ETA for a Kitkat 260 firmware :)
  8. Villa

    Villa Well-Known Member Super Moderator

    I haven't had a chance to try it!

    Options would be to roll back to an older version or you could try this...
    http://www.minixforum.com/threads/wasser-3-0-6-android-lollipop-5-1-1-rom.15152/
    ...as there will not be any more official updates.

    Personally I am still using an old YouTube version on other devices as updates have broken the functionality of the app with the device.
  9. charlesp

    charlesp New Member

  10. Yujah

    Yujah New Member

    Thanks for posting that but unfortunately, no change here with 12.32.59 either; the above mentioned video is still sound-only in the YouTube app. Could you confirm or deny that precise video to work for you in the YouTube app, version 12.32.59? And are you on the Kitkat 250 firmware?

    It's also not a hit or miss type of thing for me; have by now restarted that video dozens of times while checking and it has never worked in the app. If it does for you, I guess I need another video to test with since we are then apparently seeing different problems.

    I was quite happy to see someone having posted a working version already when I checked back here. Darn :)

    Let me by the way also be precise about the version I installed: from your apkmirror link, version 12.32.59, arm, 240dpi, Android 4.1+. The 240dpi is as reported by "Droid Hardware Info" for my X7.
    Last edited: Sep 15, 2017 at 10:36 AM
  11. charlesp

    charlesp New Member

    Hi,
    I confirm your video "When customer refuses to pay" is black with sound on my X7 with youtube 12.32.59.

    However all the other I was having issues (regular 720p unlike yours at 720p60) started working again.

    So yeah problem not fixed. As for the DPI the different ones will make it so that the text and menus are smaller or bigger. Depends on how you like it since everyone's tv is different.

    One option if there is no firmware fix could try other previous versions until we find one that work. We could also try to find other 720p60 videos see if they do the same things or if there is a pattern.
  12. Yujah

    Yujah New Member

    One again thanks. Yes, I will get on trying succesively older versions, I hope this evening.
  13. charlesp

    charlesp New Member

    For your info this video becomes black at 19mins. The first 19mins work great. 2-3 weeks ago it was working just fine.

    And I know because my daughter has been watching it every morning for the last 3 months :p

    Could people post the url of the non-working videos? This could be useful for testing

  14. Yujah

    Yujah New Member

    Tested a number of recent and semi-recent versions without seeing a change in behavior, then went back to 11.47.72 (last version of 2016) and did see a change; not in the sense of working video, but in the YouTube app actually noting that "A problem occurred". Same thing for 10.49.59 (last of 2015).

    In a sense that might be progress, what with the app at least knowing there to be a problem rather than just silently failing but that doesn't of course actually mean much. Given the explicit error, tweaking the HLS settings sounded perhaps more promising there, but no, no change. It's very much starting to look like a supply-side problem -- although as far as I've been able to determine limited to the actual YouTube app on Android 4.4 (Kitkat); everything's fine inside of a browser on the X7 as well as in the XBMC YouTube addon. In any case, I'm starting to suspect we might not be able to fix anything locally.

    That Wasser 5.1 firmware I'm not particularly keen on; seems to be a bit of a mess judging by the thread(s) and when I go sit in front of the TV I do want something to just work, rather than continue my day-job of endlessly debugging software issues. Also not looking forward to going back to the Android 4.2 firmware; at the very least the permanent on-screen error wrt. weather (or time? not sure anymore) in the home screen is rather annoying, and if I recall correctly, getting my A2 Lite remote working wasn't easy or even possible either. Have for now given up; mentioned child will just need to use a PC or the browser for now. These Android TV boxes are not, let's say, "functionally sturdy" ...

    I can confirm your video to have the issue you mention. On the two mentioned old YouTube versions it starts to play but definitively stops with the same "A problem occured" once you seek (i.e., to 19 minutes). Only quiting and restarting the video works to start it again, with the same result upon seek. In the new YouTube version, the video crashes on a black screen.
  15. charlesp

    charlesp New Member

    Hi,
    Since I know for sure my video was working last month and now it does not on previous youtube versions, lets not exclude the problem might be on youtube's side.

    Yes it's working on other platforms but we might be more affected by this issue.
  16. Yujah

    Yujah New Member

    Yes, indeed, that's what I meant: seemingly a server-side issue rather than anything we can fix locally on our systems.

    But well, might not be true. The YouTube version I tested were Android 4.1+ and 4.0.3+; so at least should work on our 4.4 systems. Just now tested with 12.32.60 on a 4.2 tablet: works fine. I guess that going back to the 010 firmware (i.e., 4.2) might be in order. Or perhaps the problem seemingly being very 4.4 specific gives someone reading this an idea for a fix...